Can't install win 7 home premium 64 Bit on wd30ezrs

Yesterday I bought an My book Essential 3TB to use as my backup/home shared drive. I then realized that I needed a new drive in my home machine more then a backup drive (my HDD in this machine is very old and I think it’s about to kick the bucket). So I took the HDD out of the enclosure and tried to install Windows 7 HP 64Bit on it. My board is ASRock h61m-HVS. It does support 3TB drives and it allowed me to start the installation from EFI. I initiatd the drive as GPT to allow windows to use the whole thing as one partition and tried installing. The installation goes through just fine, but on reboot it gives me an 0X000025 error and that’s as far as I can get. I tried to install twice, to no avail. I also tried to initiate the drive as MBR, but in the proccess I get two partitions (2.2TB and 765GB), but I am unable to acess the 765GB partition at all, so that’s out of question.

I understand that by taking the drive out of the enclosure I likely voided the warranty. I don’t mind that.

I just want to get windows installed before the main drive does fail.

Can anyone help me. Pretty please.


Even if your Windows installation is detecting the drive, and you can see it in your BIOS, I recommend you to confirm with ASRock that your board supports a 3 TB drive, and that you can use it as a bootable device.