Can't install western digital dashboard


On Windows 7 SP1 I am having trouble installing the WD SSD Dashboard. What is confusing is that it says download error even though I am trying to install the file as opposed to download the file.

I tried installing it in safe mode and compatibility mode. I do run the file as administrator. I’m open to other ideas.


I believe the file we download just goes to a server and then downloads and installs the Dashboard. That failure might be due to a lot of different server related issues.

See if this link helps. It’s from the Downloads option at the top of this page just in case you feel more secure using it. I’ve had problems before as well. Seemed I was getting two different versions from two different places. This link was the one that worked for me. LINK

Thanks for the tip, but I still get the same results. I am pretty sure the trouble is on my end, but I am just not sure how to approach this. I might have to try some third party software.

I believe I was able to get it to work. What I did was download an earlier version from then I used that to check for updates to install the current version.