Can't install, WDSmartware. for USB3, WD Essential 3TB

I can’t install the WDSmartware software. I’ve had a problem with this drive, a replacement. After I hooked it up, windows started to install it’s drivers. Before I could stop it, because I wasn’t paying attention, they were loaded. I’v tried everything to install the WD software, but no luck. I reformatted the drive, which I believe was a mistake, now I can’t install Smartware and I might has well have junk on my desk for the good this drive is being. Can anyone come up with an answer? By the way, I’ve tried several downloads of WDSmartware, it won’t install

You’ll need to download the ISO image and put it back on the drive

then you can install the software

download the software here

The website you directed me 2 was for an SES driver.  I downloaded it, installed it, and tried to start the WDSmartware.  No luck!  Not only that, I can’t right click on any thing without a dialog box called " WDContexMenuHandler" not responding.  The message within this box states, “Failed to load Locale file-C:\Program Files\Western Digital\WDSmartware\Locale\WDSmartware.tmx”.  What’s that all about?  I’m worse off than I was before!