Can't get camera to send Pics to FTP on EX2

I have a Avacom camera on my network. I am trying to get it to send pics to the EX2. The test says Device(WIFICAM)

Test  ...  Succeed

I have a share in the EX2 that has full read wite  User access to the share folder. I have enabled both FTP Access and WebDAV Service under Network Services and the share folder.I have rebooted and shut down.

I have a Wire shark capture that shows the login and the picture file it’s trying to upload to the EX2. I get a  “553 Users may not upload files” The EX2 seems to not set the share folder for the user. Is there a way to set what folder will be used by the login?

Thanks for any help

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

220-You are user number 1 of 10 allowed.

220-Local time is now 23:11. Server port: 21.

220-IPv6 connections are also welcome on this server.

220 You will be disconnected after 10 minutes of inactivity.

SYST

215 UNIX Type: L8

USER cambd

331 User cambd OK. Password required

PASS mypassword

230 OK. Current restricted directory is /

TYPE I

200 TYPE is now 8-bit binary

PORT 192,168,1,231,136,249

200 PORT command successful

STOR HSL-086176-CFZRY_0_20150727231121_5.jpg

553 Users may not upload files

553 Logout.

Welcome to the Community.

Hopefully an experienced user has been able to successfully accomplish what you are trying to do and is able to point out if there’s anything specific to consider.

AdrianP15 wrote:

I have a Avacom camera on my network. I am trying to get it to send pics to the EX2. The test says Device(WIFICAM)

Test  ...  Succeed

I have a share in the EX2 that has full read wite  User access to the share foulder. I have enabled both FTP Access and WebDAV Service under Network Services and the share foulder.I have rebooted and shut down.

 

I have a Wire shark capture that shows the login and the picture file it’s trying to upload to the EX2. I get a  “553 Users may not upload files” The EX2 seems to not set the share foulder for the user. Is there a way to set what foulder will be used by the login?

 

Thanks for any help

 

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------

 

220-You are user number 1 of 10 allowed.

 

220-Local time is now 23:11. Server port: 21.

 

220-IPv6 connections are also welcome on this server.

 

220 You will be disconnected after 10 minutes of inactivity.

 

SYST

 

215 UNIX Type: L8

 

USER cambd

 

331 User cambd OK. Password required

 

PASS mypassword

 

230 OK. Current restricted directory is /

 

TYPE I

 

200 TYPE is now 8-bit binary

 

PORT 192,168,1,231,136,249

 

200 PORT command successful

 

STOR HSL-086176-CFZRY_0_20150727231121_5.jpg

 

553 Users may not upload files

 

553 Logout.

 

Go to NAS webpage --> Share tab and enable FTP access for folder you would like to give FTP access to.  I believed you only turn on the FTP from the setting but have not enable with share folder to allow FTP access to.

I Did do that before and rebooted still not going to directory. " I have enabled both FTP Access and WebDAV Service under Network Services and the share folder"

Below You can see me use W7 ftp.exe. If i change the directory with the “cd” comand, i then can send file.

ftp> open 192.168.1.240
Connected to 192.168.1.240.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 10 allowed.
220-Local time is now 16:33. Server port: 21.
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 10 minutes of inactivity.
User (192.168.1.240:(none)): cambd15
331 User cambd15 OK. Password required
Password:
230 OK. Current restricted directory is /
ftp> put ftptest2.txt
200 PORT command successful
553 Users may not upload files
ftp> cd CamBD
250 OK. Current directory is /CamBD
ftp> put ftptest2.txt
200 PORT command successful
150 Connecting to port 54059
226-File successfully transferred
226 0.007 seconds (measured here), 1.83 Kbytes per second
ftp: 13 bytes sent in 0.00Seconds 4.33Kbytes/sec.
ftp>

AdrianP15 wrote:

I Did do that before and rebooted still not going to directory. " I have enabled both FTP Access and WebDAV Service under Network Services and the share foulder"

 

Below You can see me use W7 ftp.exe. If i change the directory with the “cd” comand, i then can send file.

 

ftp> open 192.168.1.240
Connected to 192.168.1.240.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 10 allowed.
220-Local time is now 16:33. Server port: 21.
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 10 minutes of inactivity.
User (192.168.1.240:(none)): cambd15
331 User cambd15 OK. Password required
Password:
230 OK. Current restricted directory is /
ftp> put ftptest2.txt
200 PORT command successful
553 Users may not upload files
ftp> cd CamBD
250 OK. Current directory is /CamBD
ftp> put ftptest2.txt
200 PORT command successful
150 Connecting to port 54059
226-File successfully transferred
226 0.007 seconds (measured here), 1.83 Kbytes per second
ftp: 13 bytes sent in 0.00Seconds 4.33Kbytes/sec.
ftp>

Then you can point your camera to ftp to that folder.  EX  (ftp:user:password//192.168.1.10/Public) 

Camer will not take it. Could not use in browser too.System report has a ftp xml file. The path seems to be there but does not change when you enter user.

Sorry typo, it should be ftp://username:password@192.168.1.1/Public   (192.168.1.1 replace with your NAS IP address)

Sorry typo, it should be ftp://username:secretcode@192.168.1.1/Public   (192.168.1.1 replace with your NAS IP address)

That does work on a browser but the camera does not take a URL string. It only wants a server name or ip address.I have a older camer that will let you selct the folder but the HD one does not. :frowning:

Sorry, it seems like you would have to call Avacom to get support how to config using the application they provide to ftp to NAS and cd to a folder that you want.  Either that or use the SMB/CIFS protocol.

LOL This is their response. By the way, thanks for your help!

Hi Adrian,

We don’t currently have this configuration option available. We found that most FTP server programs directed the uploaded files to directories based on the user name. What FTP server software are you using?

Thanks,

Ray

On Thu Jul 30 12:56 , wwwrun@weebly-app4.eig.weebly.net sent:

I have the Avacom H5060W.

I’m trying to use alarm that will send to a FTP server. The FTP requires the client to select the folder it will up load to.

How can I do this? I have a older cam that did have a folder option.