Can't find a specific Windows share?

Hi all.

I’ve had this unit for about a year and haven’t had too many problems with it thus far. It even recently started playing full 1080p for me!

However, my unit has not been able to find my Win7share (desktop over wireless network) the last day. I think the issue might be because my Windows machine fell asleep when I left my WDTV Live on overnight on accident. I’ve done this before and restarting the Live usually works.

However, this time I’ve restarted the Live, reset it to factory settings, and restarted my desktop to no avail. I can access the shared folders on another computer connected to wireless on my network. The Live also finds my girlfriend’s MacBook (not a Windows machine) under Windows shares. But can’t find my Win7 desktop.

Any ideas on what I can do? I’m at a loss over here.

Can it not see your shares with the Media Library or can it not find it if you try to access it directly as a Network Share?

The latter. It shows the “Media Library” of my desktop, though I do not have that set up. I can’t access my desktop directly as a Network Share. 

chasely wrote:

The latter. It shows the “Media Library” of my desktop, though I do not have that set up.

???  I’m not sure if we’re talking about the same thing there.  Media Library are shares you have added to the SMP, not Media Server.

Are you sure that you have the folder(s) you are trying to share, shared correctly?

Have you checked to make sure that the SMP is on the same Workgroup?

My apologies. The SMP finds my computer if I add content source as “Media Server”. It does NOT find my computer under “Network Shares.”

I am nearly positive that the folders are shared correctly, since I can find them on the network using a wirelessly-connected laptop.

Similarly, I’m pretty sure the the SMP is on the same workgroup since it can identify my desktop as a “Media Server”.

Sorry for the confusion.

Workgroup doesn’t have anything to do with Media Server, you can connect to a Media Server without the same workgroup.

You need to make sure that they are have the same workgroup for shares.

Thanks for the clarification. Both the SMP and the desktop have the workgroup set as “WORKGROUP.”

To my knowledge, I didn’t change any settings on either side before it stopped working.

Edit: I see you have done a factory rest.

I tried a factory reset after a few restarts of the SMP didn’t work. The factory reset didn’t work either.

Try this.

Turn off your PC.

Then unplug the power cord from the  SMP.  Turn you PC back on and wait for it to completely boot, then plug the power cord back into the SMP.

Still no luck. Just get the spinning arrow for a few minutes.

Ok, so if you could access the files before, but can’t now, something must have changed in your network settings.  Have checked to see if your on the same network on both you PC and SMP?

If you don’t know how to check, let me know and I’ll try to walk you through it.

Same network as in the right wireless network? Yes they are both on the same network.

Have you tried setting a static IP to the SMP?

I have not yet, and don’t see how to do this on the SMP side.

My PC does recognize “WDTVLive” under “Media Devices” on my network, and the IP addresses under the properties on the PC and on the SMP match up…

Thanks again for your help.

On the SMP, select Setup, then select Network Settings / Network Setup.

Then select Wireless, which I assume is how you want to connect, then select Auto Search.  When you see your router, select it, put in your password,  then it should ask you whether you want to set it up Automatic or Manually. 

Select Manual and input the IP address, Subnet Mask, Gateway and DNS (Gateway & DNS should be the same).  Then click Finish.

Does it matter which IP address I assign my SMP? I set it to the address given by router ( 

I did have to set the Gateway and DNS to be the same ( - the routers address.

With this configuration I still had the same issue.

No, it doesn’t matter as long as it doesn’t conflict with the IP of any other device on your network.

You also need to make sure that your PC as the same Gateway & DNS.

I changed my PC to have the same Gateway & DNS (under TCP/IPv4 - v6 doesn’t work for that?). Still have the issue however.

Did you try restarting you PC after you change those?

Also, just for measure, did you try to ping your SMP from your PC?

Have you tried rebooting your router?

But I will tell you this, if your PC under Network doesn’t list your SMP under Computers, then you still have a problem somewhere in your network.  That your SMP can see the PC as a media server and the PC can see the SMP as Media Device (Server) then I doubt that the problem is with the SMP, but somewhere still in your network settings.

The last thing that I know that you can do is to turn off you PC, and your router.  Turn you PC back on and let it boot, turn on your router, then try a factory rest of the SMP again.