Can't download WD Align software

Earlier this week, my 8 month old WD20EARS backup drive has suddenly slowed down to throughput speeds to as about 10MB/s. Speeds start off normally, but then drop off. A ten-fold drop in throughput speed makes it completely useless as a backup drive if it can’t keep up with the backup process. I started googling, and found that this is a known issue, and that I should run WD Align. Then my problems began.

First off, the drive is in my backup PC. It’s on SATA controller, and has been working fine as a backup for several months. I have no idea what triggered the 99.99% slowdown. I checked for PIO mode, but it says it’s still DMA. I even took it out and put it in an external USB dock and tried it on my primary system, and it also has pitiful throughput.

I ran a test copy of a 280MB file, and what I get is:

C: drive (SATA) takes 7.5 seconds

F: drive (eSATA) takes 5.7 seconds

L: drive (USB) takes 10.1 seconds

X: drive (IDE, over gigabit network) takes 15.19 seconds

P: drive (WD20EARS) takes 8 minutes, 57.2 seconds

Okay, so I need the WD Align utility. Great. I find it at I try to download it, but clicking the download link just takes me to, where I can “manage my account”. I’ve got the **bleep** drive registed, it’s still under warranty, but I can’t download the bloody software I’m told I need to fix it!

Going to the “Products Registered” page, next to “In Warranty”, there’s a Download link. So, I click the download link, which takes me to the page, which has a link for “Advanced Format Software”, which takes me to…

This of course, is where I started in the first place. If I click on the Download link, I am of course taken back to “Manage My Account” again.

And, no, I don’t want to pay to extend my warranty, I just want my **bleep** drive to work. Is there any way to defeat WD’s stupid, stupid, download page to get the god **bleep** software I need? No, I don’t have a popup blocker. No, I’m no blocking javascript. No, I’m not blocking cookies.

Okay, I found these links:

which oddly enough, didn’t appear when I originally searched for “Align Tool” in the search box.

Anyway, this answers my question. It’s not me or my setup, currently WD does *not* make the alignment tool available to anyone, they only claim to. Not only is the file not available to users on the web site, tech support apparently refuses to send it to people, too.

The *bad* news is that the software (downloaded from another source) reports that my drive is already aligned, so that’s not the cause of the terrible performance.


I had also notice this issue on the download link

Currently waiting for a response from support