Can't do Time Machine on new MBLD 6TB: AFP error when attempting backup

Hi folks. Thanks for all the useful advice here, which helped me gain network access to the MBLD inside the Time Machine disk selection list and generally configure things to work.

I can now use my MBLD to copy things over the network but aren’t able to do Time Machine backups from my main home Mac, a Mac Mini running Snow Leopard 10.7.5. I can access the TM share on the MBLD from the Mac, either with smb://, afp:// etc prefixes (not sure of which I should use for TM, but tried all), but once the backup starts I get the AFP error and can’t perform it.

I am aware that this was covered in another article a year ago which proposed a firmware update, but I have the latest MBLD firmware already. The MBLD is fully accessible via gigabit ethernet connection to an Asus DSL-N55U wireless modem-router, with the Mac accessing the wireless network.

I have tried everything: reboots, factory restores, the “defaults write TMShowUnsupportedNetworkVolumes 1” trick, everything… but I just can’t get it to work… sooo frustrating… I would not recommend this NAS to my worse enemy now.

Could any kind soul here offer any help?

Thanks in advance and happy new year


Hello, check if the link below helps. Try verifying again if you really do have the latest update.

Thanks. Your tip didn’t help though… I did have the newest firmware.

I have solved it, but don’t really know how since I did a number of changes at the same time:

* Upgraded Lion 1.7.5 to Mountain Lion 1.8.2

* Did FULL factory restore of MBLD (took 2 days)

* Left MBLD open, no passwords

Working now… but taking ages to backup…

Thanks anyway


I also had the newest firmware and the same problem.

Like you, I solved it but don’t know exactly what the fix was. But it was less drastic than your full factory restore and new OS.

Short story:

 - used the MyBook dashboard webpage to delete old backup share

  • created a new share *with a different name than the old one* (this may be the key as recreating with the same name is what introduced the AFP error);

  • left it as public-access;

  • restarted MyBook and Mac;

  • set it up in Time Machine

The reason for deleting the old backup share was that Time Machine had deemed its archive “unreliable” and needed to start over. (It always does this within a couple of months after starting one … perhaps it is Time Machine itself that is “unreliable”). I wanted to give it a clean start so decided to wipe the backup share first. But deleting from the dashboard had problems: it times out after 5 minutes but it seems to take longer than that to delete the .sparsebundle.

After the share finally disappeared (another mystery, seemed like it just needed enough time), I recreated the backup share *with the same name as before*. That’s when the AFP error cropped up.