Can't connect to WD My Book Live Duo (in network)

Hello,

I can’t find my WD My Book in the network (with a netscan) or in the clientlist of my router.

It is booting with a blue light at the front but that becomes yellow quickly.

It is connected with a UTP cabel -> tried different cables and even tried it at a friends house for a different router.
The hard drives are spinning.
The two LED lights from the Ethernet port are working. The one at the top is blinking an the bottom is steady.

I tried to reset the device by holding the reset botton for 20/30 seconds while the device is on. (tried it with the device off also)

Anyone a clue how I can get it functional again?

You might want to read the manual.

A “20/30 seconds” reset is not a documented procedure, so not sure what you’re expecting to accomplish with that.

An IP Reset is four seconds in duration, with the device booted up.

I found this:

Important: The User Manual for the My Book World (White Light) incorrectly states that you need to hold down the reset button for only 4 seconds to reset the device. The correct information (20 seconds) is in the article below.

So thats why i did 20 seconds
But i also tries 4 but no luck

The My Book World is a totally different product than the My Book Live…
I assume you have have the My Book Live (Duo) because that’s where you posted the question.

I have a my book live indeed but in tried 4 seconds first but it has no affect… so any suggestions?