Can't connect MyBook Live to new laptop

I have a MyBook Live that I have used for several years. Several months ago I purchased a new laptop (Dell Inspiron running Windows 10). I realized that I forgot to connect the MyBook & tried to do so today. I downloaded the software from the WD website & followed the instructions. Since the drive was already connected to power & to the router, I unplugged both cables to start the process. I waited several seconds, and reconnected the Ethernet & then the power cable. The front light glows blue. It will change to green but then changes back to blue after several seconds. The two rear lights are blinking green & steady yellow. When I run the scan as directed in the instructions, the drive isn’t found. When I check Windows Explorer, the drive doesn’t show up. I’ve checked the help topics but none seem to help. (Can’t follow most of the help directions because things aren’t working as described in the directions.) Any suggestions? (At the very least, I’d like to be able to access the files that are already stored on the drive.)

Here are some things to check in Windows. In the “Advanced sharing settings” of the “Network and Sharing Center”:

  • Make sure your adapter (wireless or Ethernet) is using the “Private” profile. (If it is using Public there are some gymnastics you have to perform. Search the web for “Windows 10 make this pc discoverable”.)

  • Make sure “Turn on network discovery” is set.

  • Make sure “Turn on file and printer sharing” is set.

That adapter profile is the most likely setting to be wrong and the trickiest part to set right. It can get changed from “Private” to “Public” for a number of reasons, and I think the Win10 default is “Public”. Here are a couple of things I remember off the top of my head:

  • UAC has to be set at medium or lower for the Make this PC Discoverable" option to be displayed. (You can change the UAC to a higher level after you set that option.)

  • NetBIOS over TCP/IP has to be enabled for your adapter, and that setting is really buried. When you find it, you can set “On”, 'Off", or “Auto”. If you have a static IP address, “Auto” defaults to “Off”. That is documented, but poorly. And there are some undocumented things that also make “Off” the automatic default.

  • Connecting to a new router will automatically switch the adapter profile to “Public”. (I found that out last week when I got a new router.)

Windows 10 seems to purposefully set up roadblocks for NAS use, but you can get it to work with a lot of patience. It’s best if you have some inanimate object on which to vent your frustration during the process. Nearby animate objects will appreciate it. :slight_smile:

Thanks. Profile is set to “Private”. I found that hint in some of the other community posts. The front light on the drive is still switching back & forth between blue & green. Not blinking - just staying blue for several seconds, then switching to green, then back to blue. Drive is still not shown in Windows Explorer. Would resetting the drive help? I haven’t tried that yet.

You could try resetting the device, but there are probably some debugging steps you could try first. A solid green light means the drive is ready. A solid blue light (except for right after restarting the device) means the NAS is is standby mode - the operating system is up and functioning but the disk is shut down to conserve power. Both are good states - Windows should be able to communicate with the device and should see the defined shares. (In the blue state it just wouldn’t be able to access the data. I’m not sure why you should be switching between them, though.

Can you get at the MBL dashboard - either by name or by IP addr - from a browser on your computer? If not, there is something more basic wrong here than Windows “sharing” settings. If you can get to the dashboard then I bet there is a setting wrong somewhere.

Is this the only NAS in your local network? If not, is it possible that you have given two of them the same name? That would confuse Windows (and maybe your router). Can your router see the device?

I just noticed that the light on the drive is now steady green (I guess I just hadn’t waited long enough previously - it took a bit longer than the “few minutes” the instructions said.) So I tried to rescan. I keep getting an error message saying the the drive cannot be found. I don’t know what the name or IP address is. It’s been several years since I installed the drive to my old laptop (which isn’t very functional anymore). It’s the only NAS I have. Also not sure how to tell if the router can see the device. I don’t have a problem getting a new NAS for backup but I’d like to be able to access the files on this one. I have a lot of photos stored on my old laptop that I’m having trouble accessing. I’d like to be able to access them on the MyBook so I can transfer them to the new laptop. Thanks!

I may be going off in the wrong direction so I hope someone else joins in the conversation soon.

I think knowing the IP address of the MBL is going to be pretty important, regardless of the problem because that will let you get to the MBL dashboard. Your router almost certainly has an administrative GUI, and that GUI may have a display of what’s connected to it. And since the DHCP daemon on the router is probably/hopefully providing the MBL with it’s IP address, the router should be able to tell you what it is. (Of course you will have to know the router admin’s id and password. That may be a problem.)

I don’t know if it will be important, but what make and model router do you have?

Pretty sure the router has no GUI. It’s pretty old. It’s a Westell modem/router that was provided by Verizon. (I have Verizon DSL.) According to the label on the bottom, it was made in 2009. Model number is listed as A90-750015-07. It also says “ADSL2+ Modem Router”. I just looked a little closer. It has several Ethernet ports and the MyBook is connected to the E1 port. It has status lights for each of the ports and there is a green light next to “E1”. I would assume that means it can see the connection for the drive.

The green like on the Ethernet port means that your Ethernet ports and cable are ok, but if, for instance, your router and MBL are defined with different IP subnet masks the two devices won’t talk. Or if the MBL is configured with a static IP address that just happens to be the same as the router’s IP address (Highly unlikely!) they won’t talk.

I’ll see what I can find out about that router. In the mean time, bring up a Windows command prompt and issue IPCONFIG. Among the things displayed will be “Default gateway”. It will probably have a 192.168.1.x or 192.168.2.x IP address (although it couple possibly be 10.0.0.x). (Those are all private IP addrs that are local to your LAN.) Try connecting to that addr with your browser and I bet you will get an admin web page on your router. I’m pretty sure they were doing that even in 2009.

Update:
I found an online copy of the manual for the router. It’s address is 192.168.1.1 so enter http://192.168.1.1 in your browser. The manual talks about changed the admin password, but I don’t see that it mention the default password. A web site at http://setuprouter.com/router/westell/a90-750015-07/login.htm says the default password is “password”.

Thanks. I was able to access the user page for the router/network. It shows several wireless devices connected (I forgot that it would count my tablet, e-readers, etc.) but no devices connected via Ethernet - which is how the MyBook is connected. So I guess the router isn’t seeing it.

Hmm. Bad news. I don’t suppose you have any other Ethernet device sitting around, do you? It would be nice to know if it’s the MBL or the router that is not doing Ethernet.

Maybe it is time to try the reset to factory defaults. If there was something changed in the MBL configuration - static IP addr or some such - the reset would change it. But look in the doc before doing it. You don’t want to do a reset that would erase your data.