Can't configure Plex WD MCH 8TB

I’m trying to replace my 6TB MCH with a new 8TB MCH.
I’ve connected it, and can see it in WD Explorer, and have activated Plex on the new 8TB. Obviously, it’s already activated and configured on the 6TB.

When I try to configure it on the 8TB, I get the following:

This page isn’t working at the moment

prod-f3cd6a29c2847f1.wdckeystone.com can’t currently handle this request.

HTTP ERROR 50

If I then navigate back to the 6TB and hit Configure, I go straight to the correct page.

By that logic, I’m assuming it’s not my setup, but that there is a problem with the 8TB. I’ve tried deactivating and reactivating Plex on the 8TB a couple of times now, even rebooted it a couple of times. It’s brand new, straight out of the box so is there any point returning it to factory settings?
I’ve even tried turning the 6TB off and then setting the 8TB up from scratch, but nothing works. I can’t even navigate to it using its IP Address.

Any advice before I send it back to Amazon?