Can't boot with Blue 1TB

I’ve just built a new computer with all new parts but I’m having trouble with my HDD. When I try to boot Windows 7 with it, it fails by either going to a black screen or hanging somewhere during the initial start up.

Then I successfully installed Windows 7 with a SSD, but I’m still having the same problems when I hook up the HDD.

I have the BIOS set to AHCI, and the 1st priority is the SSD, but I can’t boot with my HDD attached…

These are my specs:

Intel Core i5-4460 3.2GHz Quad-Core Processor

ASRock H97 PRO4 ATX LGA1150 Motherboard

G.Skill Ripjaws X Series 8GB (2 x 4GB) DDR3-1600 Memory

Samsung 840 EVO 120GB 2.5" Solid State Drive

Western Digital Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive

XFX Radeon R9 290 4GB Double Dissipation Video Card

Corsair SPEC-01 RED ATX Mid Tower Case

Corsair Builder 500W 80+ Bronze Certified ATX Power Supply

Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer

Hi etye1214, welcome to the Community. Have you tried using another SATA cable or connecting the hard drive on a different SATA port. If possible you can also connect the drive to another PC. 

Yes, I have tried different SATA cables and ports. I don’t have another PC to try it on.

Have you tried running a DLG test? 

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty

I ran an extended DLG test, and the test failed with “too many bad sectors”