Can't access 'utilities' at dashboard


I just bought WB MBL and couldn’t enjoy a single minute of good experience. First it coudln’t get discovered via CD boot software, so I got to the dashboard via direct connection.

The problem is that I can’t access ‘utilities’ tab, as it shows “Loading” and nothing happens for 5 minutes and then the loading screen dissappears. I desperately need this tab to restore everything to factory settings, as I have a bunch of other problems: can’t set remote access, can’t create user accounts, set a password and access all the multimedia sharing things.

I tried to connect to it via PC & Macs, Opear, Chrome, IE, Safari and I have the latest Java & Flash player installed, but the issue is the same across all the devices.

Please, provide some help. Is there any way to play with reset button to get it rebooted?

Thanks in advance

Hi, to map the shares and to access the dashboard you can try using WDlink. You can also try pressing the reset button on the back of the my book for 4 seconds. Check the link below.

1 Like

I’ve mapped the drive once again and then reset the drive, but it still doesn’t seem to work.

Btw maybe it’s important: before the numerous server errors I’ve updated the firmware, maybe it might be the cause.

Currently I’m on my way to installing ‘Putty’ to access it via ssh. Let’s see if that helps

Ok, guys, thanks to everyone, full factory reset via SSH did work well.

Just in case a little to tip to a mac user:

don’t look for Putty analogues, just run Terminal from Apps/Utilities and connect to your drive:

ssh root@[XXX.XXX.XXX.XXX] - where X is the ip of MBL

for password enter welc0me (don’t worry, if the letters won’t display as you type)

And finally, run the command

/usr/local/sbin/ noreformat

at your own risk. at least it worked for me!

I am having the same problem.  Using windows 7.  Contacted support and 3 days later they told me to reset.  3 days after that still have no word from then.  These guys should have made a hardware factory reset.  I know that is what I have to do, but can’t get into utilities to do it.  Any advise for a windows user.  If there is a way to downgrade the firmware maybe that would help?

pressing the reset button does NOTHING to my drive…still keeps thrashing about nothing !

what the heck is that as a solution ??

I bought this drive for it to be user freindly now I need a degree in acronyms and networking again!

Did you get anywhere with this? I have the same problem and I really don’t understand what “solution” is being offered here.

Doesn’t work for me!

While I’m try to access Utilities men in dashboard (Safari) nothing happen, no bug or error code, just nothing.

For the Remote Access when I try to activate the remote access I have an error 31564  the device status could not be update due to an communication or an internal software error.


I also have the same problem - after firmware update immediately after installation of new MBL 2Tb, can’t get Utilities to open - just hangs. I need to access it to do a factory reset because I’m getting an error message against virtually any action I try to take e.g. add user, add share etc. Very disappointed with this WD kit so far!