Can't access user folder & Internal Server Error

Hi All,

I am facing an issue accessing my WD MYCloud Home for the past 5 days. I enabled my local user for my network and i was able to see and access my files on both Windows and Mac devices inside my house. For the past 5 days it stopped and shows me the attached error. I tired to login to turn off the local sharing and enable it again but I am getting another error:

" An error occurred

Internal Server Error"

I also tried to change the local user name as the same error shows internal server error.
On Mac, when I try to access the same user it doesn’t show me any of the files I have stored under it. It shows files that are not there for exmaple: Public & TimeMachineBackup. When i tried to access the files online on My Cloud Home I am able to see all of files fine.

your kind help is apppericated

This may be related to the deprecated WD Discovery which may still be running on your OS (Win and mac). Uninstall WD Discovery completely from your OSes and reboot. If that does not solve your problem, open a support ticket.

I uninstalled WD discovery a long time. I opened a support ticket

You have made a lot of changes to the My Cloud Home (MCH), but you have not mentioned if you ever rebooted the MCH after all those changes. That is another step to try.

The other step is to download the debug_logs.tar and examine the smartdata.log to see the state of the hard drive.

But most MCH homer users will just wait for the WD support to respond to the opened ticket.

I am having the EXACT same issue. I have both a Windows 11 and iMac – and, local access had been working just fine. Then, a few days ago, I simply rebooted my iMac and we can no longer locally access my personal data. Like you, we see only two folders - PUBLIC and TimeMachineBackup – but, none of our data.

We can access our data using mobile or through the web interface. The personal data is on the device and can be downloaded (etc.). It is a problem of LOCAL access (using FINDER and EXPLORER). And, without being able to use local access via Finder and Explorer, it makes the device, for the most part, useless.

We have now created a case, and talked to customer service over the last few days, without any success in fixing the issue. Customer service had me download the “debug” file via a reasonably complex method. Then, because the file cannot be sent to customer service via gmail due to it being a restricted file type, you have to upload the file to your Google Drive and then provide WD with a link. As of this typing, WD claims to have escalated the case to the “next level”.

Frustrating indeed.

1 Like

Don’t use the same local user ID for all 3 devices eg., if you use MADELP on mac or Win, don’t use that again on the My Cloud Home local access.

If you have rebooted everything and signed into My Cloud Home webapp and go to the enable local access page and log in successfully and still no access through Finder and Win Explorer [… edited out the reset part; this is most likely a firmware error.]

But use a USB HDD to backup your data first.

Thank you for this information!

With the help of WD customer service, we tried some user ID changes (etc). Sadly, it didn’t help. We have, in fact, rebooted EVERYTHING – and it didn’t help access my data via local access (Finder, Explorer). What is most confusing is that everything was working great — and, I simply rebooted my iMac and then immediately lost local access from my Windows 11 PC and my iMac.

I was told by WD customer service that the case is be “escalated” and that I should hear back from them in a few business days after they review the debug file that we sent to them.

Thank you for the update and never mind about the reset of MCH as this server error is most likely caused by a Samba error from the My Cloud Home which requires an update of the firmware from WDC.

Notice MCH release note:

My Cloud Home Firmware 9.5.0-186 Release Notes

Version: 9.5.0-186
Release Date: 08/01/2023

Updated open-source Samba package to version 4.13.13+dfsg-1~deb11u5

Under a similar situation, a NextCloud update also broke Samba with a certain subset of samba clients (not all) giving a

I am affected by this issue after our NextCloud server was updated from samba 4.11.3 to samba 4.12.3 (using the samba-heimdal AUR workaround for the broken Archlinux samba 4.12.3 package). Applying the patch #20622 (comment)
gives us back the SMB external storages. Deleting/recreating the shares was not neessary.

So just to update everyone. I opened a case with WD support and they suggested to Clear Device Settings:

and check if things work or no. If not I am to reply to them and share the log files as well as MAC address of the unit. Since I am afraid to clear the device settings, what I did was the following:

  • Got an old WD Passport HDD and connected it to the device.
  • Used the USB Copy feature in the web interface and copied all my files outside.
  • I created a new user in WD MyCoud Home and copied back all my files.
  • Enabled local share on the new user.
  • Now it is working fine and my PC and Mac devices can connect to it.

Still not sure about doing the “Clear Device Settings”, I know that in the documentation it says that it will not affect the data and I know I have a backup of my data, but I don’t want to go into the hassle.

1 Like

I had the exact issue. However, I did “clear device settings” and re-setup local access and now it is back and accessible. I did back up all the files just in case and fortunately the original files stayed intact.


I also used clear device settings but being on Windows 10 i also had the public folder mapped and I had to unmap that, reboot (log off might have worked) and log back in and I could access my personal share.

I know from the past Windows can give different credentials for the public network share and then it will not use the correct credentials for a personal share thus having to log into a personal share first to prevent that.

Hi, another confirmation that clearing the device settings seems to solve this issue. I encountered the same “internal server” error after losing access via my local network (Win11 PC). No amount of rebooting my devices seemed to work, and WD customer service (while nice) were also not much help. I came across this post and decided to give clearing the device settings a try. Low and behold it worked perfectly. Local network access has been reestablished and all of my files are intact.

Many thanks to @befree112 and other previous posters!

Thank goodness for this post. I had the same issues today and was driving me mad rebooting everything. “clear device settings” solved my issue too.

What is going on at WD?

Thank you so much for this post. Happened exactly the same, all of a sudden no more access to my user directory from local connection on my Mac. Nothing was changed. Clearing the settings and re creating the same user did the trick. No data loss.

But now the app and web access to the disk shows the directories they want ! Not all are listed. It started with only 3 and time after time some directories are added and shown. What a strange behavior. Local access is fine and all directories on the disk are shown.

Same problem here, but missing the meny to clear setting :slight_smile:

I have fix this!!
After a lot of mails with the support teams, they’ve send me this that fixed the problem. It was so easy after all this time trying…

you have to Clear Device Settings, this doesnt delete any of the users or data.

1 Like

My problem is I do not have the “Clear Device Settings” in my menu. The language is Danish, but there should be a menu - as you can see on my screendump, I only have 4 submenues…

Are you logged in as an admin? With the mail that has the device register? or as another user?

In my device that menu only appears when I log as admin, when I use a guest user there are only 4 options (like yours i guess).

I only have one user, but I solved my problem by taking a backup, made a factury reset, restored data and then it appered in the control menu. As soon I changed drive to Local, I dissappered again…
I can now connect to my share again…