Can't access shares after restoring from CleanDebian + OMV

I’ve tried to install CleanDebian + OMV but it wasn’t working at all thus I restored to original WD My cloud firmware as per:

Finally, after having some success with the restore I wasn’t able to reach my shares. I updated firmware to the newer version of WD MyCloud via ssh as through GUI I wasn’t able to do that.

After an update, I still wasn’t able to access the shares, so I thought let’s do a system restore. This worked perfectly. However, when I try to connect to the shares or WD Mycloud via finder (I’m a Mac user) it says:

I tried to create a user which would have access to all the shares but I’m still receiving the same error message. I tried to make all share Public, but still no look.

Any suggestions?


First step is to determine which single bay My Cloud version one has. Check the P/N number on the bottom of the single bay My Cloud enclosure. If the P/N number ends with “-00” then it is a first gen model, if the P/N number ends with “-10” then it is second gen and uses a different set of directions to “unbrick” the hard drive.

Personally, I’ve never used the “recovery” directions from Fox_exe. I’ve had good luck unbricking various hard drives over the years when using Fox’s first gen directions below.

User Fox_exe repositories:
Main Repository:
First Gen:
Second Gen:

First gen directions:
File(s) used in first gen:
Latest first gen firmware:

Second gen directions:
Alternate method files:
Latest second gen firmware:

Notes on running unbrick directions: After successful unbrick one can update the My Cloud to the latest firmware. When running the first gen unbrick directions from User Fox_exe I typically get one or two errors, which I tend to bypass.The unbrick process typically completes despite these errors. Places where I typically get warnings or errors:

  • Step 8. The command ‘mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2’ sometimes throws an error. I typically just ignore the error and continue to the next entry command in step 8.
  • Step 12. When using the original_v04.01.02-417.tar.gz file, I get a out of space error when running the command ‘dd if=kernel.img of=/dev/sdb5’. I typically ignore this error and proceed to the next entry command in step 12. When using the original_v03.04.01-230.tar.gz extracted files I do not get the out of space error message on sdb5.
  • When booting the My Cloud for the first time after unbricking the hard drive I eventually get a red front LED after the bootup completes. I then attempt to access the My Cloud Dashboard. If I am able to access the Dashboard I run a Settings > Utilities > System Factory Restore > System Only restore. This typically fixes the 0K capacity and the failed mount issue that typically happens with this unbrick procedure.

Thanks, got a couple of errors along the way but at least now I’m able to connect and see shares using Finder.