Can't access share with other users


I’ve just bought a MBL 1tb NAS drive for my home network. 

I’ve copied all data from my old NAS to the new MBL NAS drive into 3 new folders (1 with my name, one for my wife and 1 MEDIA folder).

From my wifes account I can see all the folders she is assigned to, but it is impossible to enter them (not allowed it sais). The strange part is that I can enter all the folders over the website when I log in as my wife. 

Also I can make MBP time machine backups and use the Twonky services on my television / mobile phone and Xbox 360

How can I make that ALL the users can see and R&W all the public folders. The above mentioned problem also regards the Admin as I have 3 different accounts with same rights…

Thnx for your reply

Please post the EXACT, COMPLETE error message(s).

The error message is as follow:

The folder ** can’t be opened because you don’t have the right privelages to see the contents (the original error is in Dutch so I translated it).

It seems that alhough that all users have full privelages only the one who copied the folder / files can read / write them, the other users can’t even read the folders.

Someone has a clue whats wrong in the settings with this, or should I contact WD directly over mail?

Is that the ENTIRE error message?

Does it not say:  “Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.”

Yep thats the enitre message. I’ve tried to log off the other users in the system. 

The root of the drive has the following folders

* Folder with my name

* Folder with wifes name

* Folder; MEDIA

* Folder Public.

All folders are public and all accounts have full access to the whole drive. When my wife or the admin user logs in, neither of those accounts have access to the sub-folders in the drive (so media can ben entered, but e.g. foto’s not anymore). 

The strange is is though, that if I connect over the wd2go website, it all works as it should, also on my wifes account. But then it sais its logged in as WEBDAV instead of her name. 

So i’m clueless about what to do. Maybe a factory reset??

Any ideas? 

The strange thing though, is that it seems that i can be logged in at the MBL with the same account on 2 pcs’s at the same time. We were both logged in on the MBL browsing folders under the same user account (mine).

Nope – no ideas;   the only time I’ve seen that error above was when it was coupled with the additional error message I describe in the prior post – or are you saying that MY error message above is ALSO displayed in your case?

 it seems that i can be logged in at the MBL with the same account on 2 pcs’s at the same time.

Yep; that’s completely normal…  Any arbitrary number of PCs can access a share simultaneously.

Thnx for your quick reply. I only get my original error, nothing more. 

Also: In my opinion it is strange that the same user can be active from 2 different computers (so emailadresses). That it would be mutiuse is just as I had expected, but not multiuse in this way. 

Ok, just to make sure that we’re ruling this out (maybe the Dutch error message isn’t the same.)

On each PC, completely DISCONNECT *ALL* shares from the MBL.

If you open a CMD window and issue the command

net use

you should see *NO* connections to the MBL.

Then reboot the PCs to flush the credentials cache.

Then log into the private share FIRST.

Note:   In Microsoft, you can only connect to a NAS box using a SINGLE set of credentials; you CANNOT connect to two private shares (with two different USER IDs) simultaneously, unless both shares allow access from the same user.

If that’s what’s causing your problem, that’s a WINDOWS limitation, not a WD limitation.   It’s not a MICROSOFT limitation (the authors of the CIFS protocol) either;  it’s just a silly limitation of Windows.

Both computers are MBP (Macbook Pro) and I can only be logged in as 1 user on 1 computer at the same time. What I do see, is that I can be logged on the MBL with 1 user on BOTH laptops at the same time. 

But IMO the whole problem with not been able to use the folders is not related to the remark above. As mentioned in an earlier post, 1 of the 3 users works as it should, the other two (incl. the admin account) can’t use any share. 

I’ve already tried to log off all users and only log in 1 of the 2 troubled users, but unfortunately that doesn’s solve it. I think im going for the hard reset. 

Ooops … my bad.   I was thinking Windows this whole time.


I recently changed the passwords on my shares to match my Windows (Vista Home Premium 32bit Service Pack 2) password.

I get this error message wheneever I try to connect to the MBL/MBLD now.

WD Link allows me to map the drives, but then when I attempt to access the drives, I receive the “Multiple connections not allowed” error.

All I want is:

To map the drives

To access the drives

To have the mapped drives remain accessible after a reboot

What is the most straight forward way to achieve this?