Can't access new WD Blue SSD


#1

Hi,

I have a new WD Blue 2.5" SSD. I want to connect it to my laptop to clone the HD. The HD and the SSD are both 1TB drives.

I have an external enclosure that I have used several times before. When I plug in the new WD SSD - nothing. If I take another SSD (an old Crucial) or an old HD (a WD black), they are identified immediately by Windows 10 and are readable from the external enclosure. When I plug the WD Blue SSD in, nothing. I have repeated this several times. I have tried this on my desktop and on my laptop. Same results.

So what do you think. The WD SSD is new out of the box. Might it be dead? Will it not recognize until I do something with it? I have cloned SSDs before (none recently though) but I don’t remember this problem. Is it time to send the SSD back? Any advice would be appreciated.

Thanks in advance.


#2

Have you tried connecting it and then using Windows Disk Management to place a partition on it? Disk Management may even ask you if you want to initialize the drive first. Some WD drives and USB interfaces just don’t work well together. Some USB enclosures and USB adapters will hide the WD info.


#3

Hello,

You are the best. I feared the worst, but hoped the best. Thank you for being my angel today. Worked like a charm.

Have a great day and a wonderful 2019.

Regards.


#4

Love a success story! Happy New Year!