Can't access NAS My Cloud Ex2 Ultra using SSH from outside the local network

Dear WD Community,
I usually access my NAS My Cloud Ex2 Ultra using SSH via linux command line. Like this:

ssh sshd@IP.adress

I have no problem to access this way on any computer in my local network, using the Ubuntu for Windows terminal.

The problem is when I am connected from a remote network, i.e., out of the network in which the NAS is connected. No matter the network I am connected to (my phone’s shared network, or a wifi from my parents home), I ALWAYS get the following error:

ssh: connect to host 192… port 22: resource temporarily unavailable

I tried every solution I found out there, but nothing works so far. It seems to me that somehow the NAS is blocking the incoming connections from computers from an outside network. Do you know what can I do?

Thanks a lot in advance!


The ip address you are using (192.168.xx.xx) is a private ip network intranet address. It is ONLY valid within your network. Intranet addresses are assigned by your router.

If you are on another network,. that is a separate and distinct private intranet network, with IP addresses assigned by the Other router.

If you are using a phone hotspot; your phone actually is acting as a router, assigning IP addresses within the phones own private intranet.

If you want to connect from one network to a device on another private network, you have to connect through the router, using the routers WAN (wide area network) internet address. This WAN address is assigned by your ISP.

There are a number of ways you can find your WAN address of your home router.

As you might expect, knowing the WAN address for your home router is insufficient. You need to tell the router exactly where on the network you are trying to connect. This is where ports come into play.

You will have an external port (This is where your Router listens to internet traffic) and an internal port (this is where your NAS listens to intranet traffic) In between, in your router, you will have a “Port Forwarding table”.

Let’s say your home router has a WAN address of
Let’s say your NAS is sitting on IP address

Let’s say you want to connect through external port 2022 (you could use 22)
Let’s say the NAS is listening for SSH traffic on port 22 (This is the default).

If you are in Bangladesh, or Japan, or Wisconsin; you would use you SSH program to dial up “”. If your NAS is set up to listen for SSH; it should connect.

NOTE: You may have to configure an Entry in the Routers port forwarding table to make this work.
The port forwarding table will need three bits of information:
*External port. (Where the Router should listen to incoming traffic) (in this case 2022)
*Internal IP (What device on your network the traffic heading towards) (in this case
*internal port (What port on your device the device will be expecting traffic)(in this case 22)

Port forwarding tables really come into play if you have two NAS devices on the network, both expecting traffic on port 22.

NOTE: I think you can appreciate the risks here - - → Having open ports on your router is a security vulnerability. You should actually consider looking into BLOCKING internet traffic to your NAS at the router level (of course, the fancy but barely functional WD MyCloud features would also be blocked if you do this)

Dear NAS_user,
thanks a lot for your answer! I think somehow I am getting to close to it, but could not connect yet…

I checked the router configuration as you said, and I think I was able to set the Port Forwarding table properly.
See an example of the table below:

However, still I cannot connect from an external network (I am doing these test with another PC connected to my phone hotspot). Specifically, I am trying the following commands:

ssh user@WAN_address

but i get the error: ssh: connect to host 192… port 22: resource temporarily unavailable

I also tried

ssh user@WAN_address:22

an in this case I get the error: ssh: could not resolve hostname —: name or service not known

I am not sure if the WAN I am using is the correct one. I was not able to identify this number in the router page. I am using the one getting from this web:

Is that correct?

Thanks again a lot for your time :slight_smile:

Try “sshd” as username.

Beyond that; it should work.

Note: i dont do this often, but when i do, i use putty or winscp.