Can't Access MyCloud after Turning on Media Server

I have been using MyCloud NAS for storage via Windows Explorer for years. Yesterday, I turned on media server for the Public Share Folder so my smart TV could see and play streaming video. This morning, Windows Explorer can’t find the server. I tried to access the dashboard by entering http://wdmycloud and the IP addr ( in a browser. I get error that “Server can’t be found.” My router (ASUS RT-AC86U) still sees the NAS (Western Digital) and shows the same static IP. My smart TV can’t see MyCloud today either. I tried a soft reset (holding down the reset button for 4 seconds), but nothing happened. The blue status light stayed steady didn’t flash.

I tried the 4 second reset. The status light didn’t flash, it stated steady. The instructions say the 40 second reset removes all users and share permissions. Does this reset leave the shares intact so that users and share permissions can be reestablished? I submitted a ticket to WD, but am trying to restore access asap. Thanks for any help.

Almost sounds like the drive was indexing.

What unit is this? A 2nd Gen Mycloud? If so. . . .indexing has been known to lobotomize these units for a substantial period of time.

Thank for the response. Sounds like Indexing could be the problem. My unit is a model WDBCTL0040DHWT-10. Purchased in 2016 has been working well, but seems to freeze when moving a lot of files. I was about to perform a full reset when I remembered the basic first trouble-shooting step, power off and back on. That fixed it, but still has freezing issues moving large numbers of files.

I was thinking it might be my router, but I only seem to have problems with the WDMYCLOUD and MyPassport Wireless Pro (MPWP). I was using the MPWP to backup MYCLOUD. I am ditching the MPWP and replacing it with a USB HD on my router. Had a lot of issues with the MPWP and it has been discontinued.

Also, moving a lot of data could be causing indexing.