Can't access My Cloud files after moving location

Forgive me if I’ve put this in the wrong category, I wasn’t sure which one was applicable to me and I am currently operating on low vision, so reading through each option was difficult to do. I have the original My Cloud model with up-to-date firmware and a total of 3TB of onboard storage.

I have a My Cloud device that I have just moved from one house to another, and after this move, I’ve been having an issue getting it set up with my computers. Previously, when I would navigate to the network section in Windows Explorer, right-clicking on the My Cloud device would prompt me with an option to open the drive and explore its contents or mount the drive. Now that I have moved it to this new location, I only have the option to open the device webpage, create a shortcut, or view the device properties. I also noticed that the VLC app on my phone, which could previously access the public media in the drive, will just get stuck into an infinite loop of trying to load the files on the drive, meaning that both devices that have used and have never used the My Cloud device do not properly interface with it anymore. Is there a setup step I need to go through to allow the device to let other devices see its files, or would I need to reset the device to factory defaults? This is an old model, so I’m also wondering if it’s just falling out of support with devices that have never seen it before or with newer network devices, though I’m entirely unsure.

Thanks in advance to anyone willing to help! Again, I apologize if this is in the wrong category.

Hello,

Please refer to the following KBA article to map your my cloud device on windows: How to map a My Cloud or NAS device on Windows