Can't access HDD via router from WDTV, other way round is OK!


#1

Setup:

-> WD TV Live

-> BELKIN N+ USB Wireless F5D8055 v2000ed

-> BELKIN N+ Router F5D82354-4 v2000 (firmware 2.01.07)

-> HDD attached to the router via USB.

All my PCs (WinXP) and Macs (OSX) can see and access the HDD attached to the Belkin router without any problems 

No luck with the WDTV. The current firmware i.e. non-DVD navigation 1.02.21 , can see the router network share ok, BUT any attempt to access ended up with an error “…can’t be accessed” (can’t remember exact phrase). I upgraded to

the latest BETA 1.03.22 (DVD navigation) and it is even worse. The WDTV does not see the router. HOWEVER Other network functions e.g. firmware checking and YouTube continues to work as it has always done.

Any ideas? Frustrated…


#2

Do the WORKGROUP names match?


#3

Yes WORKGROUP names are the same. Also case sensitivity is correctly entered.

Does it matter what format the HDD is in? Currently it is in NTFS. It was once formatted as FAT32, but then you can’t put a Dual layer DVD ISO on your HDD. It also was not working in FAT32.


#4

I have the same issue

-> 2 WD TV LIVE’s different places around the house

->NETGEAR  DGN2000 router

-> WD My book world HDD attached to the router via cat 5.

My laptop and xbox can access the hdd ie the media these are both wireless, 

No luck with the WDTV.

I have one with the current firmware and one with the latest BETA 1.03.22 

this setup has been working for ages until recently,

I bought a new tv so wanted to test it with a good film but now it doesnt find the media server

if i go under network shares it asks for login and password

Please

please someone help me


#5

So, what changed?   You said you upgrade ONE to the BETA.   What’d you do with the other one that made it stop?


#6

My case is slightly different from the last responder’s set-up as I have never been able to access the HDD via the router from the WDTV Live.

I can copy files with no problems to a USB HDD attached to the WDTV via wireless from my PC’s and Macs. However I don’t want to leave the WDTV on all the time to save electricity. As it is in a different room having to get up each time to turn it on and off after copying is a pain.  That’s why I want to get the HDD attached to the (always-on) router set-up working.

So is it the fault of the WDTV Live or the Belkin router? Is the only solution to buy a full blown NAS? What’s the chance that someone from WD will look into this?


#7

Look what Belkin said…

"We understand that the WDTV is not able to access the external hard drive connected to the Belkin router F5D8235 verson 2000. We will definitely help you to resolve this issue. In order to resolve the issue, you have to map the drive which is not possible using WDTV."

So what now?


#8

What it sounds like they’re saying is that the Belkin does not advertise the shares.   My NAS box (Q-NAP) has this feature as well, if I mark a share as “Hidden,” it does not get listed, but I can MAP to it.

You’re out of luck with the Belkin.


#9

userWDTV wrote:

Look what Belkin said…

"We understand that the WDTV is not able to access the external hard drive connected to the Belkin router F5D8235 verson 2000. We will definitely help you to resolve this issue. In order to resolve the issue, you have to map the drive which is not possible using WDTV."

 

So what now?

This might be possible using b-rad’s homebrew firmware:

http://b-rad.cc/wdlxtv-live/


#10

This has something to do with the security permissions associated with your drive which I suspect is formatted NTFS.  I had this problem after the firmware up grade and have not been able to resolve the security issue.  What I did was format my drive with exFAT and that resolved all of my issues. exFAT does not have all the security associated with a drive formatted with NTFS. Google exFAT and I thing you’ll find the info useful.