Cant access dashboard after factory reset

Just did a factory reset on my my cloud, unfortunatly I cant access it anymore, also tried the 40sec reset switch, but still no luck.

After first boot and selecting language it gets stuck here.

After refresh of page this is all I get.

Any help would be highly apreciated.

If you have never stopping yellow blinking light in front of your My Cloud, it may indicate bad connection to router or Internet (strangely, yellow light is not documented in user manual).

May be you can try to restart your LAN (turn off/on My Cloud, router and modem). Control network cables and unplug / plug them in several times.

Did you solve it? I have exactly the same problem.

Didn’t find a solution, so had to start over and reinstall a fresh image on the hard drive.

Well, the thing was easier than I thought. It seems all the problems started when I changed the language option in the first tab. I changed it to Spanish and then I got that screen. So I did a new 40 seconds factory reset and did all the setup in English, without changing anything in the first screen and it all worked well. After that it all works well and you can even change the language without problems.