Cannot write to external hard drive on a mac

I have a WD Elements 1042 Media external hard drive and am using a mac with a Monterey os. I have reformatted it to be Mac OS Extended (previously it was compatible with Windows), but I still cannot save files to it. It is still saying that it’s read only. I have tried changing the permissions on it to write as I have seen suggested in a few different places online but it doesn’t work. Does anyone know how I can make it writable

It seems like you’ve successfully reformatted your WD Elements 1042 for Mac, but it’s still showing as read-only. To resolve this, try checking if the drive has a physical read-only switch, which might be the cause. If not, you can open “Disk Utility,” select your drive, and click “First Aid” to repair permissions. If that doesn’t work, you may need to backup the data, reformat the drive as Mac OS Extended (Journaled) with Disk Utility, and then copy your files back.

Let me know if you need any further help.

If you have already reformatted your drive to Mac Extended ( aka HFS+), and you are still facing issues with it being read-only, there could be several reasons for this problem.
Firstly, check the physical switch and file system format. Also, Run the First Aid on your drive from Disk Utility, as it will repair the disk’s file system. You can check the Sharing & Permissions section, and make sure that your user account has “Read & Write” access.

Hi, thanks for the reply. The external hard drive does not have a physical read only switch. I have tried running the fist aid on disk utility a few times, reformated it Mac OS Extended (Journaled) and to APFS and have done alot of googleing on this but cannot find a solution , its always saying it’s read only. I have also tried changing the permissions

Since you’ve reformatted the drive, checked for a physical read-only switch, and attempted to repair permissions, the issue might be a bit more complex. Here’s what you can try next:

  1. Use Terminal for Permissions: You can attempt to change permissions using Terminal. Open Terminal and run the following commands:

    sudo chflags -R nouchg /Volumes/YourDriveName
    sudo chmod -R 755 /Volumes/YourDriveName

    Replace “YourDriveName” with the actual name of your external hard drive.

  2. Reset NVRAM/PRAM: Sometimes, resetting the NVRAM or PRAM can resolve issues related to external drives. To do this, restart your Mac and hold down the Option, Command, P, and R keys simultaneously until you hear the startup chime twice. Then release the keys.

  3. Try Another Mac: If possible, try connecting the external drive to another Mac to see if the issue persists. This will help determine if the problem is specific to your Mac or the drive itself.

  4. Backup and Reformat on Another Mac: If the issue persists on another Mac, back up your data from the external drive and then reformat it on another Mac to ensure that there are no compatibility issues with your particular Mac.

  5. Check for Hardware Issues: If none of the above steps work, there could be a hardware problem with the external drive. Consider contacting WD support or a professional data recovery service for further assistance.

After trying these steps, please let me know if the issue still persists or if you encounter any specific error messages.