Cannot view and access the files inside My Passport 500GB

I have WD My Passport 500GB, and I have a lot of files and important things inside it. I have used about ~460GB of it. I’m using Windows 8 x64 version of OS. Lastly, I plugged in my external hard drive in my friend’s computer, which was using Windows XP, and all the folders inside my hard drive were transformed to shortcuts, and when I tried to opened them they were opened but in a new windows. After I unplugged the hard drive from there and tried to plug in it again, I couldn’t find my files inside. I have tried plugging it to a few other computers and laptops but the same problem persists. In my computer it shows that my hard drive is about ~460GB full, but when I open it inside, I have just the following four files:


System Volume Information (it is as a shortcut)

WD Quick Formatter

WD SmartWare

I don’t want to format or lose my data inside the hard drive. If someone could help me retrieve my files and solve the problem, I would be glad. Now I will be scanning the hard drive with Windows Update, and it says that there might be potentially harmful things, but I have to wait until the scan finishes. I will inform you again after the scan is complete, whether the problem persists or not.

It sounds like something is corrupt. Maybe TestDisk or Recuv will help.


Windows Defender found few viruses and similar stuff, but deleting them didn’t solve the problem. I also tried running analysis with TestDisk, but I don’t know whether it does something or not. While the problem persisted. I also tried using Recuv, but I guess it is a software for recovering the files that have been deleted. When it finished the job I saw some of the files that I had previously removed, but not the files that are still in my hard drive.

The point is that, hard drive still shows that about ~460GB is used, and when I scanned for the viruses I managed to see that it was scanning my files, so they are inside the hard drive and they are not deleted. The only problem is that they are not visible. I understand that there is something corrupted with the hard drive, but I don’t know how can I fix it.

I would get rid of the Windows Defender and get real AV protection. I use Avast free. The MS versions score poorly in tests.


I solved the problem. Those repairs and sh**s don’t do anything. The only thing that I needed to do was to type this line in the command prompt:

attrib -h -r -s /s /d f:\*.*

Note: In my case my external hard drive letter was F, don’t forget to change it according to yours!

pls sir allow me to hug you. you just saved my passport with 460 gb of files. thank you very uch and have  a nice day

What does that prompt do?


ATTRIB is a Windows command, that is used to set and remove file attributes. As I had written in my earlier posts, the point was that the external hard drive was showing that it has files inside, meaning it is not empty. But when you opened the hard drive, inside you couldn’t see the files. If you tried to make the hidden files visible, it still didn’t help, and you weren’t able to view the files. Also if you do a virus scan or something similar, it was showing that the files were inside and that they are scanned. Finally, if you apply the command that I had written, it solves the problem, and then you are able to view your files inside your external hard drive. So no need for anti-virus, anti-malware or drive tests. You can read more about attrib command here.

I’m glad that it helped you husara.

Great info. Thank all of you for commenting and discussing.

I just received my MyPassport 1TB USB-3, and going to use on a Windows XP computer.  However, I am in process to find a new Windows 8 computer.  Did anyone figure out what caused the file attributes to change ?  Since you loaded/worked in the W8 system, then only viewed in WXP, is this a common thing ??  so I should not use on XP then W8 ?  Any thoughts are appreciated.

hi…i have the same problem with wd my passport 1tb can you can help me how to solve this thanks!