Cannot use remote access on My Cloud


#1

I have three WD devices that I have used for years. All three devices have been networked with remote access through my My Cloud app on my iPad or iPhone. Recently, through a series of events, I have lost the ability to access one of these devices.

I have the “My Book Live”, and two “My Cloud 2T” NAS’s. I recently went from TWC to AT&T Fiber. When I connected my NAS’s directly to the new router (which I had done with my old router) only two of the three devices would boot up. The one that would not boot up was one of the two My Cloud devices. It’s a little older than the second My Cloud. Not knowing why, I decided to try to reboot the device by doing the “40 second” reboot. Nothing would work. I came to the realization that this device would not work being connected to the AT&T router. So, I connected all of the NAS’s to my Ethernet switch box. Now they all boot up and I have access to them all.

The reason I am writing is because I cannot use the remote access app on my iphone/ipad to access the My Cloud 2T that I had the issue with. The other two NAS work fine remotely. I have logged into my device and tried reestablishing remote accessibility, but it does not work. I have even compared the two My Cloud’s to see why one works and the other does not. I have not tried to reboot the troubled My Cloud, for fear of messing something up. Any help would be greatly appreciated.


#2

Correct; that’s a well-documented problem between the MyCloud and AT&T Uverse router.

Have you remembered to give the two MyCloud devices different names (after you did the 40-second System Only Restore?)

Have you deleted any existing device connections (i.e. in the mobile app) via the old ISP/router, and created new connections via the new ISP/router? See ‘Manage Devices’ in the app menu.

Which device did you reboot (40-second reset), then?


#3

What I meant to say was that I did not try to reboot the My Cloud again, after I got it up and running.


#4

My NAS devices (the two My Clouds) have different names, as they did when connected to my old router. I will try to delete the existing devices in my app, then try to connect again anew. Thanks!


#5

I didn’t realize it was that easy. All I did was remove these devices from the app, then connect them again. Thanks for all the help!


#6

And that fixed your access problems?

Good.