Cannot Use Microsoft MS-Access file on WD myCloud?

I have an MS-Access file saved on WD MyCloud. If I try to open the file in MS-Access (Takes very long time to open), I get errors that the VBA files have errors (which they don’t).

If I go to File, Compact and Repair Database in MS-Access, I get an error (after a very long time - 5 Minutes at least) that I get an error message “the compact and repair operation has been cancelled. You might not have adequate permission to the folder…”

I ensured I have full access using the dashboard. Has anyone been able to compact and repair an MS-Access database which resides on the WD MyCloud?

Does WD My Cloud not support running Microsoft applications?

Thanks
Dave

Or does Microsoft Access not support loading Access files from NAS devices like the My Cloud?

Have you tried mapping the Share containing the Access database file then pointing Access to that mapped share?

Yes - I mapped the WD Folder to X: drive. I go to my X: drive using MS File explorer and go to the folder. I open MS-Access database. I try to repair and compact and it fails everytime. This is very repeatable with the same result using different database files.

What happens if you copy that Access database from the My Cloud to the local computer, does Access still try to repair it or have trouble opening it? If not then it would appear Access has trouble opening a database file from the My Cloud.

I have several MS-Access databases and all have always worked fine on all computers on the network, when they are opened locally from the hard drive of the computer. The only time I have ever seen this error is when I copy the file to My Cloud and try to open the file there.

If I copy to My Cloud, then back to my Local drive, the file is identical, and it still works fine when opened from the computers local drive.

So then it appears that WD My Cloud does not support all Microsoft Office applications. Has anyone tried to run an MS-Access file from the WD My Cloud and had similar issues?

I have a problem whit a base of access 360 in a PR4100 and the computer it’s a windows 10. Before I use windows 7 and no problem