Cannot mount mypassport osx 10.9 mavericks


i cannot mount mypassport 2TB anymore. is it out-of-order?

or wont it work under 10.9 mavericks? is there a known bug?

i got it in april 2013 from amazon.

it wont be mounted at all (USB 3.0), i tried my new imac late 2013 with 10.9 and my macbookair 2013 with 10.9, it wont show up, but spins. i tried it with different usb ports, too.

i didnt use the apple wd tools ever, just formated it as “mac osx extened journaled” some time ago. (guid partition)


Hi, try running a test using the disk utility app. Check the link below for the steps. 

How to test a drive for defects or problems on a Mac 

thanks, that was the first i did. i know harddisctoolkit and i tried to mount the mypassport drive.

but it is NOT showing up in the list of harddrives in the app.

i requested a new drive from wd, and it came today, the old i send back

same problem, it wont show up in the finder and it wont show up in the list of drives in harddisctoolkit app

(10.9 mavericks, tested with my 2 macs, late 2013 imac 27" and mid 2013 macbook air)

another idea: i downloaded the osx tool “WD Drive Utilities” and there, the mypassport is listed!

but not in the finder, and the “WD Drive Utilities” cannot mount the disc.

i tried to repair and format the brand new disc coming today from wd, and there is an error:

“could not format the mypassport disc because of an error”

third idea:

i installed wd security:

the mypassport is not showing up in the app

i installed wd turbo drivers for 10.9

it still wont show up in the finder and in any wd app / harddisctoolkit

any idea? i am helpless now

by the way, i did a test:

as mentioned before i have 2 (or more) mypassport drives, each 2TB, and i cannot

mount or see them in the finder and in the apple disc tool app **under 10.9 (**and we never have been running any wd software on our machines ever.) i am on 10.9 on 2 of my macs (latest 27" imac and mabookair)

i connected both mypassport drives with the old macbook air of my wife running 10.8 (with latest system update), and there everything is fine,  i can mount all my wd drives on 10.8 ! nothing is destroyed here.

so i reformated the drives with apple disctools under 10.8 and tried them connecting to my new imac with 10.9: still no mount possible.

lets wait for 10.9.1

do you know, if apple is responsible for the driver in mac osx or does wd deliver the driver?

if apple codes the hard disc drivers, we must wait until they react on the problem, right?

i hope that at least one apple coder has a drive from western digital !

still no news? I have the same problem

I posted more info and details on the other post “My passport ultra not mounting on Macbook pro 10.9”

I’d appreciate at least a confirmation from staff whether the problem has been repeated or not confirmed by them

Question to Brille… where YOU able to fix it and if so, how?

Best regards and thanks in advance

 Brille, did you find a solution for this connection issue with MyPassport ultra drive on Mac. Or have you ended up returning teh drive. I’m scurrying around this WD Comm page to see if anyone post a solution to the matter. Only one dude, mentioned that there might be a possibility of insufficient current going through the default USB3 cable that the drive came with.

Pls let me know if you came up with a solution. I don’t believe WD didn’t warn Mac users about this issue. Maybe that is why the latest product release is MyPassport Ultra for Mac. Coincidence you think?

I have this same issue as well.  I purchased my drive fall of 2013 and haven’t ever updated the firmware.  I’m going to try that this morning after backing up.  According to the firmware release notes I’m at least one version behind and there are fixes that sound like they address this problem:

I switch using this drive between an OS X 10.9.1 and Windows 7 machine.  It’s formatted exFAT.  Drive security is enabled.  The failure for the drive to mount occurs intermittently on both machines.  I am using the original drive cable directly connected to the machine.

For a while I was convinced that the issue was Photoshop Elements, which has a process ElementsAutoAnalyzer that runs at startup on both machines.  It tries to work with the photo catalong located on the WD drive having problems.  Once I stopped that process from running at startup the drive stopped having problems on the Windows machine.  Unfortunately, the Mac still has issues, sometimes mounting only WD Unlocker.

no, as mentioned in many other threads, here and at macuser and at apple discussions i did not find a solution.
i returnec it and got a new passport drive with cable. same problem. i closed my case at wd forums and sold my wd drives at ebay, i stay with lacie and caldigit, which works on 10.9

This is a follow-up to my previous post.

Updating the drive firmware to the latest version for my “My Passport Ultra” drive appears to have corrected drive mounting issues for my MacBook Pro running Mavericks (OS X 10.9.1).  I tested cold boot, warm reboot, wake from sleep, eject and remount, and mount after boot - all worked as expected.

Unfortunately, you need a Windows machine to update the firmware on the drive.  I could not find a Mac updater.  The update software may be downloaded from Western Digital here:  WD Product Update

This may not work for your “My Passport Ultra” as firmware updates vary by version of the drive.  My drive’s serial number ends in “01” and the firmware was updated to v1.025.  If your drive serial number ends in a different 2-digit revision, you will get a different firmware update.  The firmware updater release notes have more information:  Universal Firmware Updater Release Notes

I had the same problem, but the WD support line resolve it. Maybe it will work for you.

If you have any data on the WD drive be sure to copy it off before following these steps to re-format your drive for compatibility with Mavericks.

With Mavericks OS based Macintosh off, plug in My Passport for Mac and boot-up the computer.

Open Disk Utility (located in the Applications > Utilities folder).

Select the My Passport harddrive on the left side of the Disk Utility window.

Select the Partition tab at the the top of the Disk Utility window.

Under Partition Layout select 1 Partition.

For Name enter “My Passport” (or whatever you want to call your drive).

Click on the Options button and select the first option “GUID Partition Table” and click OK.

Click on the Apply button in the lower right of the Disk Utility window and wait for drive to be reformatted.

That’s it.