Cannot map MyCloud to a network drive?

#1

I’ve recently purchased a 6tb MyCloud drive and have been trying to get this set up. I’ve got my first lot of content loaded through the online portal,. but I am struggling to map the network drive as I cannot find it to map.
Any help would be great.
Thanks

#2

For starters you CANNOT officially map the My Cloud remotely. WD removed that capability last year. You can only map the My Cloud while connected to the same local network as the My Cloud. Further if you are on the same local network as the My Cloud there is no need to use the MyCloud.com web portal. Instead one can simply use Windows File Explorer, Mac Finder, or a file manager app for one’s mobile device to copy data to/from the My Cloud.

More information on how to map a My Cloud Share:
http://support.wdc.com/knowledgebase/answer.aspx?ID=2676

http://support.wdc.com/knowledgebase/answer.aspx?ID=2686

If you haven’t done so already you should read the My Cloud User Manual (http://support.wdc.com/product.aspx?ID=904) to understand the various features of the My Cloud and how to use them.

Unofficially, and absolutely not supported by WD, if one has an older first generation v4.x firmware version My Cloud they can install the unofficial CloudDAVMod to regain the ability to remote map their My Cloud. This ONLY works on the older v4.x My Cloud and one cannot downgrade a newer v2.x firmware My Cloud to the v4.x firmware as the two single bay My Cloud models use different hardware and different firmware.

https://community.wd.com/t/app-clouddavmod-various-versions-for-firmware-v4-09-2016/161543

#3

Thanks for your help.
I am trying to map from my PC which is on the same local network as MyCloud (to enable my video contact to be searchable by Plex), I understand ill need to use the the mycloud web portal when outside the network.
I have already tried following the mapping guidlines you have linked to above but my problem is that my MCloud isnt visable under the Network area of my PC so I cannot compelte this. I’ve read through all the help material I can find and nothing has helped. The error i get is"Windows cannot access \WDMyCloud. Check the spelling of the name. Otherwise, there might be problem with your network.

#4

Can you access the My Cloud Dashboard?

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13965

Have you tried using the IP address of the My Cloud rather than the name when mapping the My Cloud? Check the router’s administration page(s) to see what IP address it is handing out to the My Cloud.

If using a Windows PC, do you have FIle/Print sharing and Netbios over TCP/IP enabled? Is the network configured for Private and not Public? Is the Firewall blocking access?

#5

Yes the dashboard is working fine and the Mycloud uploading portal.
Yes I have tried using the cloud’s IP address as shown under settings of the dashboard, even cross checked this again the router and they match.
Where do I find these settings on my PC as they are beyond my technical knowledge. I’ve checked the firewall and this seems to be ok.

#6

Control Panel/Network and Internet/Network and Sharing Center/Advanced sharing settings

Also make sure the Workgroup matches that set in the Dashboard

Control Panel/System and Security/System/Computer name, domain and workgroup settings/Change settings

#7

If your using Windows 10 see the following thread which has some things to check, in particular Specific Method’s 1, 2 and 3. Couldn’t hurt to do General Method 1 and 2 if you haven’t already.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#8

the xbox one adapter for pc to connect wireles controlers interfeers with the cloud making it not show on map device just unplug it and it will work… "if you have one " and check if u have any virtual network or etc…

#9

This is an older post, but I’ve been banging my head. The gist of this awesome post is: if a group doesn’t have access to a private share, then neither will the user. Even if that user has explicit access.

My solution was to remove my users from groups. And voila, I can access their private shares.

#10

Note that the single bay My Cloud units, the general subject of this subforum (My Cloud), do not have “groups”. It only has Users and Shares. There is no group option in the single bay My Cloud Dashboard.