Cannot log on to WDMYCLOUD

I have just changed my router and now I have a problem logging in to WDMYCLOUD. What is strange is that I can access all the folders through Windows Explorer (both public and password-protected private folders) and I can also access them through the WDMYCLOUD application (the one with the blue and white icon) but if I try to access via the grey/white icon (which takes me to a web address, in my case it keeps rejecting my password (I know it’s correct because I saved it in a password-protected Roboform safenote). Any ideas?

so you are getting to the dashboard but can’t sign in. Correct?

if this is the case I would do the 4 second reset which will reset the password and change it to DHCP so you can reset both

you will also need to clear that roboform since the password will be reset

Not sure how to do the 4-second reset but this could be useful for future reference if someone could explain.

Actually, I have resolved this particular problem. I think someone said that you had to have the same password that you use to log in to Windows, so I tried that and it worked. All sorted now. Thanks for your help.

there is no requirment for the user and password to match between the PC and mycloud. good that it works now.

there are serveral reset / restore procedures:

4 second - power on press and hold the rear reset botton for 4 seconds, resets password (at lease the admin user) and networking to DHCP

see the manual for the others