Cannot label MyBook Studio LX drive...Help!

As i’ve read in the posts here alot of people are having an issue being able to use the labeling feature on their MyBook

Studio LX drive. Yet a couple of people have said they have had no problem. What gives? I just called customer support and all he said was that if it wasnt working then he guessed they should put a fix in the next update. So obviously he wasnt aware that this was an issue. I am running Mac OS 10.6.8 snow leopard and have tried others’ suggestions about trying to uninstal and reinstall the WD software, use all the updates, and even tried using both firewire and USB cable but it will neither update the label or the amount of free space thats on the drive, even thought the Smartware itself will show how much space is being used up on my computer and the Mybook on the Smartware home screen. Yet when I try to update the label and hit ‘save’ it does try to send it to the drive because the little white light flashes three times, but nothing else happens. And I have already loaded about 1TB of info onto the drive no problem, yet the label is still stuck at what it came with (basically empty). If anyone has had any success with this, I would really appreciate a response. Thanks in advance!

I have the other version of the My Book Studio and the E-label is working fine, sometimes, if I connect the drive to a compute that does not have Smartware, it erase the label.

 Tried this in a Studio LX drive of a friend, he is using Leopard to, the E-label is working, he was having the same issue that you are having. He just download the latest version of WD Smartware, uninstalled the old version, restarted the computer and installed only the latest version.

Thanks for the reply!

Yes I tried that already but it didnt work for me. DId you use firewire or usb cable when you did that on your friends leopard?

Also how was the Studio LX formated? I used the apple disk utility and formatted it using the GUID partition (which is what is recomended for a Mac Pro). I’m wondering if that makes any difference. Thanks again.