Cannot install SmartWare. Freeze on installation

I cannot install SmartWare for more than 6 months. I taught there was a problem with a driver or something similar and for that reason get stuck on " scanning for hardware changes". Today I just installed a new copy of Win 10 Pro 64bit but there it seems to be the same problem. In fact it freeze my PC completely and the only way to get out is to restart from button. I have a WDMyCloudEX4, MyCloudMirror and a MyBookLive on my home network all together 30TB and I’m very frustrated by not being able to make a simple backup to my files. Somebody else complained here about a similar problem more than two years ago, marked as solved…by restoring computer to previous software version. That’s not my case. If somebody have a clue about the reason of my problem, your help will be much appreciated.

Hello,

Are you trying to install the latest version of the software from the WD Support site?

If not, please try that. See if this helps.

Yes - tried multiple downloads of latest version. Same thing happens every time.