Cannot "find" Mybook live drive

Hi everyone. I’ve had a 2tb mybook for about 2 months now but haven’t managed to get it working yet. One of the reason I went for this model was the supposed ease of use as I’m not a wizz with computers and the terminology. Anyway, when rtunning the installation CD it can’t “find” the drive when it searches for it. I’ve tried it with the firewall and security turned off and still nothing. Tried it with the laptop plugged into the router - no better. The drive seems to be running as it should regarding all the lights, etc, and my TV has picked it up, but no idea why my laptop won’t.

I am using Virgin cable via a Linksys router and was wondering whether it was the settings on the router that was causing the problem? Can anyone help a layman out as I’m massively frustrated with this product!!!



Try finding it directly in a browser by typing http://mybooklive in the address bar. If the web UI shows up you can then find the IP address from the Settings > Network menu options

I have had a similar problem, but got there in the end. The following may help. Through your router, set a static IP address for the MBL. Google how to do this. Ultimately, my problem was caused by my anti virus software, Kaspersky 2013. I completely uninstalled this and reverted to the 2012 version. See my posts

Hope it helps.

Funnily enough I am using Kaspersky 2013 aswell so will follow your advice and try it out at the weekend. Thanks for the help!