Cannot find my device from browser using www.mycloud.com\setup

I am having issues finding my MyCloud device using a browser. I have successfully installed and am able to see my MyCloud files using my iphone and ipad and can open the MyCloud app on my PC but I cannot access using my browser…I have gone through the step of entering my devices MAC address and I am updated to the latest firmware…I have also made sure the uPnP is enabled on my router and still no success. Does anybody have any idea what might be going on?

Hello Jeff_Briggs,

the adress “www.mycloud.com\setup” is only used for first configuration of the MyCloud. If the device is already configured you should get a message similar to “This device has already been set up”.

To access the dashboard of your MyCloud use "http://<devicename>/"
(default name: mybooklive = “http://mybooklive/”) non-case-senstivie

What OS are you running? What Browser are you using?

I can access the “console” view by going to http:// its when I’m at work and want to access files that I can’t see my device when I go to mycloud.com/setup it can’t find my device. I do the “search” and it starts searching and never finds it…has me enter the MAC address of the device and still can’t find it and directs me to WD support

Windows 7, using Chrome browser

The reason why the device could’nt be found is because it isn’t in the same local area network as the Client you try to access from. To use the cloud service sign in at http://www.mycloud.com/

Also Make sure the user account has cloud access permission.

I don’t think I’m doing very well at describing my issue…my MyCloud is on my router at home, setup and working, I have files saved there and can access them with my ipad or iphone. When I am at home on my PC (which is connected to the same router as my MyCloud) I can use the WD My Cloud app on my PC to see all my files just fine. I can even use the WD My Cloud app on my PC at work and access my files. It is when I try to use the Chrome web browser that I am not able to access my files.

When I sign on to www.mycloud.com, I Sign In with my UN/PW and am presented with a screen that says “No Devices Found / Please notify the devices owner (or Admin user)”

I am certain that the user (me) has cloud access permission.

You can search the forum for “Chrome” and find plenty of issues using that browser.

Download the user manual from WD.com. On the dashboard under settings, Cloud Service should be enabled. On the dashboard under Cloud Access, click on your username. Make sure that the part that says “My Cloud Account for…” has the email address that you used when you set up your MyCloud.com account.

Then you should be able to login to your account at mycloud.com.

What happens when you use another web browser like Firefox or Internet Explorer / Edge?

1 Like

I tried Internet Explorer tonight and had the same results as with Chrome.

1 Like

Cloud service is enabled and the part that says “My Cloud Account for…” has my email address that I use to sign on with mycloud.com with

1 Like

I have same problem exactly same with you :frowning:

I didin’t find any explain or video for this issue