Cannot Edit/Select folders to backup other than C drive

Using the new WD Backup software with a new My Passport. Latest software, etc.

The software recognizes the My Passport just fine. My data is on my D drive. When I go to the “Select Files to Back Up” screen and click on My computer, nothing happens. There are no Drives/Folders shown below “My computer.” The user manual states clearly that I should be able to choose another backup source.

How do I tell the software that I want to back up from another location? It seems a lot of people have this problem, but I can’t find a solution. I sent multiple messages to WD support, with no answer.

The old Smartware worked fine, but does not work with the new My passport drives.

Have you tried re-installing the application directly from WD’s Support site? It appears to be a rendering/function error.

Yes, I tried that.

At 03:58 PM 1/13/17, you wrote:

Has there been no other answer? This is the same problem that a bunch of people are reporting in this thread:

I have the same issue. Reinstall of latest software from the website did not fix the problem for me (Windows 7).