Cannot delete folder from MyBook World 1TB with Mac

I am unable to delete a folder from my networked WD MyBook World 1TB external hard drive. The folder is originally a backup from Memeo from my Windows 7 notebook. I am now using the drive with Time Machine to back up both my MacBook Pro and my wife’s. Whenever I try to delete the folder I get the error message that a folder (“output”) is in use. I have tried terminal commands to delete it. I have tried using Windows 7 in Parallels to delete it. Windows says it is deleted but then the folders magically recreate themselves on the drive.

I have tried “sudo rm -rf” in Terminal and I get an error that the directory (for every subfolder in this folder) is not empty. I cannot “cut” the folder to move it to another drive in Finder.

I can cut and paste using Explorer in Parallels the folder My WD_Backup from partition Public to partition Download on the MyBookWorld drive, but then when I go back to Public it still exists in both Explorer and Finder.

The exact error message when trying to delete in Finder in “The operation can’t be completed because the item ‘output’ is in use.”

I have tried rebooting both my Mac and the network drive to no avail.

Any ideas would be greatly appreciated. 

Have you tried calling wd tech support on that issue?

Try connecting to the device using the guide detailed here:,209,263

I was having exactly the same issue but this access route seemed to work for me. It also shows up config folders for the drive so be careful!

Hope this helps.

That solved the problem.  Thanks!