Cannot Consistently Access MyBook Live NAS

I have a network that is pretty simple.

  • ATT DSL model/router.
  • MyBook Live NAS attached by Ethernet to the router
  • 2 identical Dell M2800 laptops running Windows 10 that connect to the network via wireless. Both are typically within 10 feet of the router.

Neither laptop is able to access the NAS 100% of the time, but one more often than not cannot access it. Usually, by restarting the laptop, NAS and router I can eventually get it working. But in a day or two, it’ll stop.

  • I’ve checked that all belong to the same Workgroup
  • I’ve run through this link and tried most of the suggestions there.
  • I did not edit the hosts file, however.
  • I have not turned on SMB1 and am unwilling to do so because of the security risks. Because it works with one laptop more often than not, it seems that (despite WD’s documentation) that it is not necessary.

I’d like to consistently be able to log into both laptops and have the public share of my NAS mapped automatically every time. Right now one works probably 90% of the time, the other maybe 30% of the time.

How can I fix this?

Well, I had ATT come out to fix a warning light on my DSL modem. In the process they reset my modem and now neither computer can access my hard drive. I can see them in the network area and I can access the UI, but I cannot access the files.

I restarted both computers, no change. I then checked file and printer sharing and found it got turned off, but turning it back on had no effect. I also rebooted the drive with no change.

Very frustrating that my drive is suddenly useless.

Does WD even monitor this anymore?

When Windows 10 sees a new router it will change its Ethernet adapter’s current profile from “private” to “Guest or Public”. If the “reset” of your modem/router made it look like a new or different router then you are in this situation. (I have no idea what Windows uses to identify a “new” router.)

The technique to change the network profile is documented many places on the web. One such place is


It has also been discussed in this forum but I can’t find those entries right now.

In any case, make sure you using the Private network profile. Also, make sure your computer is “discoverable”. (That used to be equivalent to using the Private profile, but Microsoft may have changed that.)

It’s still labeled as a private network, however I discovered that I cannot enable printer & file sharing. When I look at the settings, it’s turned off. I turn it on and click save settings, but when I go back in it’s turned off again. This is happening on both laptops.

Currently Googling for answers. The suggestions in this thread did not help:

https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/windows-10-keeps-turning-file-and-printer-sharing/3597d645-d74b-42c4-b54b-3441773541af

Any other suggestions?

One other thing I can think (but cannot find at the moment) is the “NetBIOS over TCP” option. It’s well hidden and I have search the web for instructions. It has to be enabled. The Windows default is “Auto” which allows it to be on when Windows thinks it should be on. But some configurations make Windows incorrectly set it off. You can safely set it on if you are always connected via a private network. sorry I can’t remember more details.

I found the TCP/IP NetBIOS Helper in the services list. It was running and set to “Manual (triggered)”. Since it was running and I still have the problem, I don’t think this is it.

Thanks for your help.

The service is required (I think) but that was not what I was referring to.

Get to Network and Sharing Center. (I use the Control Panel, but you can get to it via Settings. There are a couple other ways, too.)

Double click on “Change adapter settings”.
Right click on your adapter and click “Properties”. (Admin authority is required.)
Select “Internet Protocol Version 4 (TCP/IPv4)” and click “Properties”
Click “Advanced”.
Select the “WINS” tab.

There you will find the NetBIOS settings: Default/Enable/Disable.

It looks to me like Default should work, but it doesn’t always … even if you do not use static IP addresses.

Well, I figured it out. Contrary to my initial post, I turned on SMB1 (client only) and I can now see the NAS.

This is turned off in Win 10 1803 because of ransomware security risks. I really don’t like turning it on, but I’ve tried so many things on various sites to no avail. This is the only thing that’s worked.

I’m not certain it’s an issue with the WD hard drive since I couldn’t see any computers on the network or even turn on file sharing with SMB1 turned off. Interestingly, my daughter’s laptop (MS Surface Book 1, also running Win 10 1803) can see the network just fine.

I have no idea how to figure it out either. I don’t know if having the client on and the server off is safer or not.

For now I’m leaving it on because I need access to these files.

A bit more info.

This post:

Implied that a registry change to remove a dependency on SMB1 was the issue. I made the registry change and removed SMB1 again, but the problem returned.

But, later down in that thread here:

Indicates that enabling the SMB1 client is not where the risk lies, it lies in the server. So, I’m turning the SMB1 client on.