Cannot connect to private share from Vista explorer

I have a private share defined that was previously working fine, but suddenly I cannot access it through Windows Explorer or any of my backup programs.  Previously, I was prompted for a username/passwd which allowed access, but now the username/passwd are not accepted as valid.  I’ve even changed the share folder to public and I’m still prompted for a username/passwd…  The root folder of the share does show up when browsing from Norton Ghost and other applications, but when I select the folder for backups, I get an access error.  I have rebooted both the PC and the mybooklive but that didn’t help.  After this problem first showed up, I noticed that MioCrawlerP is running on mybooklive and consuming lots of CPU.  I also noticed that the the folders underneath the shared folder name are owned by user ‘www-data’ and have permissions of 776.

Any suggestions?  So far, the My Book Live is a real bust!

Open the command prompt (CMD.EXE) and issue the command:  NET USE * /DELETE

Let us know if there is something shared.  Answer Y if there is.

Immediatly after you done that try and authenticate to the MyBook Live using your desired user name and password.

Let the community know what happens.

That cleared the PC network so that I could then access the share.  Ironically, the share was currently marked as public from the mybooklive dashboard, but I was still prompted for the username/password.   However, the username/password was accepted and I was able to proceed with a Ghost file backup.  I still don’t understand why I see two entries for MYBOOKLIVE in my PC Network folder.  One of them is not accessible and the other one is.  But for the time being, clearing the network connections with net use * /delete opens things back up.

This is a problem with Windows Vista and NOT the MyBook Live. It’s also annoying and ANYONE with any make and manufacturer of network storage will be liable to hit againt this problem.

Windows Vista goes scanning for resources the user has access to like network storage devices and printers and then Vista tries to be kind to the user by listing them. Only problem is when it encounters the NAS then it logs in anonymously and the MyBook live accepts this as a guest login so, effectivley, your computer IS authenticated to the MyBook Live. When you try authenticate with your desired credentials the username and password dialogue keeps popping up but Vista will NOT tell you that you can’t authenticate with more than one set of credentials to the same storage device.

Now…   If you use the NET USE command from the command prompts and Vista encounters this problem then that console command WILL tell you what the problem is.

So, you have to remember to delete any authenticated connections to the MyBook Live first.

Yes. It’s a pain in the proverbial rear. :angry:

Don’t know why the MyBook Live appears twice in your network places.

It’s not clear to me what mechanism Windows is using to “login anonymously”.  Are you referring to the Samba configuration or to the guest account listed in the /etc/passwd file?  I run Samba on a Fedora Linux computer to which I connect without any problem.  When I try to open a private folder, I’m always prompted for a username/password and access open as long as I’m logged into Windows.  But I’ve never encountered the problem I had with the MBL.  So is it really a Windows problem or a problem with the way Samba is configured on the MBL?

i first created a private share via the web interface, then i sucessfully mapped the share on one machine (win 7). when i tried to map the private share on another machine i got the invalid cridentials error message regarding, could not map the drive on my second machine. i tried ‘net use */delete’ command but an error 67 came up, network name cannot be found … possibly because my wireless network is set to invisible ? btw, does this command only need to be issued on the machine that’s having trouble mapping the share ? what about the other machine that has the private share already mapped ?

Question…  Did you use . . .

net use */delete

 . . . or . . .

net use * /delete

 You should be using the second of the above two.

syntax error on my part, ill issue it again … so when i do this on one machine, does it affect the authentication i established on the other?

No. Only for for the one machine so it needs to be done with all of them. It’s literally because Vista goes hunting for resources before you have a chance to authenticated with your desired credentials, but Vista will keep on asking for the credentials making it look like you can’t authenticate. It’s because Vista has already sent credentials and authenticated as a guest user. Can’t have parallel authentications to the same device.

i use windows 7 on 2 laptops to access the NAS. so far i’ve not been able to establish a sucessful map to a private share from one of the laptops regardless of what i do. i issued the net use command on the machine i’m having trouble with, restarted, still can’t access the private share. for the username i am just inputting the username i established on the mbl private share. should i use //drivename/username instead ?

Don’t restart. Map the drives with the correct credentials as soon as you’ve used 'NET USE * /DELETE`.

Get Vista to remember the desired credentials.  If you can’t do that then you’ll have to use 'NET USE * /DELETE` after each reboot.