Cannot connect to network shares


#1

I had my WDTV Live Plus working fine for the longest time…but just recently I purchased a new Linksys E2000 router. I haven’t used my WDTV since buying the new router and today when I tried to connect to my PC it is saying it can’t connect to the network shares. I don’t recall configuring anything on my router before, but maybe I had something configured from a previous device. Is there something in the router that needs to be setup so the WD and PC can connect?


#2

If the E2000 is anything like the E3000 (which I suspect, it is) it may have taken over the role of Master Browser.

The E3000 doesn’t perform that role to the satisfaction of the WDTVs.   Go into the Web Configuration of the E2000 and try changing its workgroup name to something OTHER than “Workgroup.”

I set mine to “ROUTERS” and never had another problem with them.


#3

I don’t see anywhere in the device configuration that it is in the workgroup. I thought those were only settings in the PC and WDTV?


#4

Yeah, I just checked the E2000 manual… It doesn’t have the same features as the E3000.

Another thing to check:

When I replaced my FiOS router a while back, my PC began to think that it was now on a NEW NETWORK, and had changed all the security settings to PUBLIC (which is more restrictive).   Once I set the network profile back to where it was supposed to be (HOME NETWORK), that problem went away.

untitled.PNG


#5

I have everything set the same way as I have in the past on mine and I had to rollback the firmware and now I get invalid username and password.

I read some old posts about removing the Windows Live ID Assisstant, but it is not present on my Windows 7, 64 bit machine.

I have changed nothing as far as hardware since the new firmware gave me the MKV stuttering issue.

Anyone else have any suggestions?

I followed the video on youtube to a T and still no luck. Still tells me invalid user id and password.


#6

I’m guessing that had the same problem as you did, I had to roll back firmware and then was unable to log into my network shares, even though everything was setup the same as before.

Rather than trying to troubleshoot I turned on media streaming in the win7 network settings, and now use the media server option rather than network shares, which works fine in my situation.


#7

Media share is not an option for me as because MKV’s wont play that way.

I uninstalled the entire Windows Live Essentials package and that fixed everything. I am now able to access my network shares without any issues.

And being on the 1.03… version of firmware fixed my MKV stuttering problem.


#8

Tony P,

Thanks I went in and saw what you were talking about…switch it to home (changed 1 setting in the advanced setup) then rebooted both the PC and the WD and now I can see the folders again. Now…for some odd reason I’m missing my “Movies” folder, but I’m pretty sure I can figure that out. It must have to do with me creating new folders and moving stuff so my kids couldn’t access the movies they shouldn’t watch.


#9

I installed a new cable modem yesterday (Netgear modem/router on Bigpond cable) and couldn’t see any of my files in the WD Live media server option which runs back to my Win 7 computer with a usb WD hard drive where the files are stored. It was working fine before the change of modem.

For some reason, the software CD which came with the modem changed the permissions on the usb drive and it was no longer shared. I also had to change the workgroup name again on the computer because it had gone back to the default name. Once I did that and shared the usb drive, the WD Live could see all the folders again. Hope that helps.