Cannot Connect to Home Network - Invalid Password

I moved to a new home which required a new password. I can connect my android devices to the passport wireless device just fine.

I attempted to connect the passport device to my home network and I immediately receive the message “Invalid Password” and a split second later this message pops up " Attention, your request is currently being processed". I am entering in the correct password. I tried entering in an incorrect password and it shows the image that its attempting to connect and it takes about 15 seconds for me to get the “invalid password” message.

Will I have to factory reset my device? I want to avoid this at all costs since I did this before and ended up needing to get a replacement passport device.

Please help.

Hi there,

Have you tried manually resetting the unit? Here is a link that might help you on how to manually reset instead of doing it from the dashboard:

Hope this helps 

I suspect you are confusing passwords.

There is a MPW name and Wi-Fi password to gain access to the MPW WiFi hotspot.

There is an Admin User and optional password to secure settings on the MPW.

There is a User ID and Passowrd for your home WiFi network, which the MPW needs to know to connect to your home network. The MPW remembers the WiFi networks you have connected to, and their passwords. You need to make it forget the old password and tell it the new one.

So, this is the one you are probably having trouble with. You should be able to fix it through the My Cloud App or the Dashboard using a browser from your Android phone. Then just turn off the WiFi on the WiFI area of settings, turn it back on, and connect to your new network using the correct SSID and password

Hi RoderickGI

I don’t see how I could confuse them. I do not have a “settings” password.  I left the user ID as “Admin” and have always left the “password” field blank.

After I started having connection issues, I removed the passport’s WPA password because I wanted to focus on connecting the device to my home network. Although I felt it wouldn’t mke a difference. (which it didn’t)

I went under App Settings and cleared the cache, no change.

I select the My Passport Settings > WiFi> I see my network listed, I selected it and entered my home network password and while it says “Your request is crrently being processed” the message saying “invalid password” pops up.

“Just turn off the WiFi on the WiFI area of settings, turn it back on, and connect to your new network using the correct SSID, User, and password’” << I did this step before and after power cycling my device, prior to posting my request for assistance.

I would really hate to have to reset my device becuase this is a replacement. The first one I bought had software issues and resetting made it unusable.


Okay, try these steps. Pictures would help, but I don’t have time.

Connect your Android device directly to the MPW via WiFi.

Tap the menu (three bars) in the top left corner.

Tap settings.

Tap the name of your MPW just below the “My Passport Wireless” heading.

Scroll down to the “Wi-Fi” section, and tap that.

What you see here may vary from what I do a bit, as my MPW is connected to my home WiFi network. If you see your home Wi-Fi network name below the heading “Connect to Internet”, then;

Tap the blue “i” in a circle at the right of the name.

Tap the “Forget This Network” item.

If you don’t get the blue “i” in a circle, which you probably wont, then I think you need to do need to do a manual System Only Reset, as per page 47 of the manual.

What I’m thinking is that when you moved house, you kept the same SSID (wireless network name) on your wireless router, but changed the password. Is that correct?

If so, the problem is that the MPW remembers your old network, and the old password, and keeps trying to connect using that information. Hence the above instructions to “forget” that network, at which time you can start again in setting up the MPW connection to your home wireless network.

An alternative would be to change the wireless password on your wireless router back to what it was when the MPW was still able to connect, back at your old house.

Still another alternative would be to change the SSID on your wireless router, and set up the MPW to connect to this “new” wireless network.

Both those alternatives require a bit of work on your home wireless network, and require changes on all devices which use the network; either just a password change back to the old one, or both a password and network name (SSID) change. Both are more work than resetting the MPW.

If you do reset the MPW, don’t forget to also update it to the latest firmware, as I believe that a reset puts the original, as delivered firmware on to the MPW.

If none of the above helps, I think you need to raise a support ticket with WD.

Thank you RoderickGI,

I never get to this point "

Tap the blue “i” in a circle at the right of the name.

Tap the “Forget This Network” item." because it says invalid password.

I went with the option of changing my home wi-fi password to the old password. That is actually less work for me than resetting my device. I’m familiar with the ip address settings site for my router. Thank you for suggesting that because it worked!! I hadn’t thought of that. (Sigh). Thank you again!

I have the same problem somehow,
I have 3 routers for different purposes and connect all my devices to them through MPW.
When I try to change my wifi in mpw wifi web page, sometimes it changes nicely, But sometimes it shows the “invalid password” message. In this case I must every time check the forget this network and then reenter the password again. Is there any way to correct this pointless forgetting/reentering my ssid passwords every time?
Thank you in advance for your help,