Cannot connect 2 WD MyCloud Drives on the same network

I have searched and searched through this forum and a couple of others to find out what I am doing wrong. I just purchased a second MyCloud drive (first one was 3tb and the second is 4tb). When I connect both of them to my network windows 10 will only recognize one of the drives (which ever drive was connected first). I have tried mapping them independently, thereby giving them their own drive letter, and I have tried adding a network location…neither method works. When I click on either of the mapped locations or mapped drives, only the first connected drives content comes up. If anyone can help me figure out what I am doing wrong I would REALLY appreciate it.

Did you give each My Cloud its own name?

I did when I mapped them, I could not see how to do it from the drive configuration settings.

Go to the dashboard. Then go to settings. Then change the device name.


Trying that now…

kind of…I am now showing both drives…each was renamed, but windows is only registering the most recently renamed drive when I try and map the drive. The second drive is showing the name change, but the first drive is not showing its new name (it is showing it when I am in "This PC), but not when mapping the drive.

UPDATE…the first drive just disappeared from “This PC”. I didn’t do anything to either drive…it just disappeared.

Disregard…the cable on drive 1 was not securely connected.

It looks like that solved the issue…thank you. I am not sure why I didn’t see that from the beginning.