Cannot access WD EX2 remotely

Hi all

This one is driving me mad and I have been trying for days.

I cannot seem to connect remotely to my EX2 when I am away from my local network.
I have tried what I think are all the relevant steps to configure cloud access and have done port forwarding on both the EX2 and my Sky SR101 router.

Ironically, I can remote access the plex server I have set up on the EX2 but the not the actual NAS itself.

All works fine within my local network and I have tried the port forwarding suggested in the tutorials.

I know I am probably missing out important info but can anyone make any suggestions?

Thanks in advance.

See for plex server it will connect itself to plex server. * Do share how are you accessing plex server"

secondly the portforwarding you have done need to checked if ports are really open by going to some port checker web tool in google.

It will check your WAN IP/Public IP and see if your router accepts the port request.

Once it says green do post screen of what it says , You can very well Hide you WAN IP

Thanks for the reply - have finally fixed this by opening some ports on the router once I had factory reset it.