Cannot access WD Elements 500GB (Compatible with USB 3.0 & 2.0)

Hi, everyone.

I have bought WD Elements 500GB (compatible with USB3.0 and 2.0) on last 2 weeks.

Everything is fine when the first time i used it.

After that, i can’t access the harddisk, eventhough the windows “Notification Area Icon” showed that i already connected the harddisk correctly.

I also checked on Device Menager to see if my harddisk have any problem, but it shows that “The Device is working properly”.

I tried to update driver via online, but it shows that my driver is already up to date.

After that, i tried to disable and unistall the device, but the problem still occured.

Any suggestions or comments are appreciated.

Thank you.

Check that the USB cable is connected directly to the PC, avoid using extension USB cables or USB hubs. Check if the elements it’s recognized on the disk management window. Check the link below for the steps.

The USB cable is directly connected to the PC.

I’m not using any extension USB cables or USB hubs.

When i open the Disk Management, i can’t see the Elements on it even though the Device Manager and Notification Area Icon already showed that the Elements is connected to the PC.

Any suggestion?