Cannot access mycloud from ipad application

Most probably due to double nat i cannot properly setup users . İpad application sees the device from home network, and shows the list of users correctly. Signon is rejected with an incorrect password message. Even if i disable the password of the user and try to signon with a null password , i receive the same error. No problems in accessing from mac or pc. File browser application from ipad also successfully access the device - but doesnot ask user name and password , most probably authenticates as guest - .
İ would be glad if someone make a suggestion on solving this problem…


Have you tried reinstalling the application?

Any other mobile device that you can test?

Thanks for the reply.
Same problem from iphone also.
Upon your reply, i reinstalled mycloud application, problem continues.
Due to some network problems (network connectivity issues as dashboard says) i cannot get a login for wd2go and cannot generate code to add these mobile devices to cloud access.
But mycloud application on ipad and iphone sees mycloud device on the network, and when i tap the device, gets the user list and displays them for me to select. When i select a user without a password i immediately get a negative response saying “unable to connect to device.please verify your password and try again”. If i select a user with password requires me to enter the password. After passord entry same negative message is displayed.
As told before, accessing from pc or mac either from wd applications or with samba etc are ok. Also access from ipad and iphone with filebrowser applications are ok.

interesting but changing the dns server ip on mycloud to open dns solved this problem, as explained in :

thanks again RKFRAZIER …