Cannot access MyBookLive NAS using Windows 10

Since I converted to Windows 10, I have not been able to access anything except the Dashboard.
I cannot Map Paths, Backup, Restore, etc. using SmartWare or wd2go.
The wd2go problem is blamed on the Security Certificate, which I have accepted and stored with others that work as they should. It is the only new certificate I have accepted in Windows 10.
Has anyone developed a solution to these issues?
It used to work fine in Windows 7 and 8, but not this year in Windows 10.

The problem is that Windows 10 and MyBook Live Duo do not connect in the same way. To make Windows 10 connect to a MyBook Live Duo you need to do the following. This will mean that all computers on the network can access every file on the MyBookLive and the Windows 10 computer will connect to computers on the network which are not password protected - just like Windows XP and Windows 7 did. This is not ideal but it works.

Log into the MyBook Live Duo Dashboard
Go to “Shares”
On each share, Under “Share Access”, select “Public”
This means all network users can access the whole MyBook Live Duo but sadly this is the only way until WD write new Windows 10 compatible software. I believe they have no intention of doing this despite the fact that MyBook Live Duo is still available for sale at retail outlets. At least this way the MyBook Live Duo is still usable for something.

On each windows 10 Computer you want to use to access the MyBook Live Duo over the network.

Control Panel> Network and Internet> Network and Sharing Centre>
Click “Change advanced sharing settings” (At top left of screen)

In “Private (Current profile)”:

Tick “Use user accounts and passwords to connect to other computers”
(If you use Homegroups then maybe this could affect the homegroup)

Expand “All Networks”
Tick “Turn off password-protected sharing”

Apply changes and Restart computer.

Then in the start menu: Under “All apps” click on “Windows System”. Then right click on “Command Prompt” > More> Run as Administrator.

In the command prompt:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
Press Enter. It should say Success
Then type:
sc.exe config mrxsmb20 start= disabled
Press Enter. It should say Success

Restart the computer.

You will now have full access to the MyBook Live Duo.

Sadly this technique allows your windows computer to connect to other non-password protected computers. This is something Windows 10 was designed not to do normally. If you just have a home network then this may be a reasonable compromise in order to keep using you MyBook device.