Cannot Access my Data

Some time back I purchased a My Book Premium edition 500 GB external hard disk for the purposes of backing up data from my desktop and being able to access additional data that would have otherwise required many a CDRW. 

Lately, in trying to access some of my old data on another machine,  running Windows XP, I find that the computer does recognize the drive, recognizes that the drive has all but 52 GB free, but when I explore the drive, most of the folders that formerly contained data are listed as “empty”. All in all, the only accessible data amounts to less than 100 GB, but yet the drive still reads as having over 400 GB written. 

I have no idea what my next move can be, is there any way to retrieve/rectify any of these things? 

All comments/questions/help greatly welcomed and appreciated. 


Have you tried to connect the drive to another computer? Also can you let me know what was the backup software you use to complete the backup?

The file system of your drive is corrupted. This is a common occurrence if  you use FAT32 or logical partitions on your drive. You should be able to recover your bad sectors without damage if you use HDD Regenerator 2011.

(Not free - use trial to install and look on the ***bay for replacement exe file… Don’t setup again using zipped contents - will not work)

TestDisk is free and be careful on each step.

Good Luck.

I have tried accessing it through another computer, but that one has Windows 7, and had the same problems described in a previous thread (

Most of the files were saved through windows explorer, when I wanted access to them immediately, but there was also a handfull of system backups made using WD Backup. 

I’m currently trying HDD Regenerator. I had previously let it run after reading your council on other topics, but ran into difficulty after it abruptly ended saying the drive was not ready. 

Thanks for the help you guys. I’ll gladly provide any more info and provide updates as they come.