Cannot access data on my WD external drive

I have a WD external drive model #7500e035-00 that’s about 6 years old. I am unable to access the data or delete any data. I have tried shutting down both my laptop and WD external drive separately and am still unable to access or delete anything. Below are some of the error messages I get:

  • We found errors on this drive. To prevent data loss, repair now.
  • Windows was unable to repair the drive.
  • An unexpected error is keeping you from deleting the folder. Error 0x8007045D: This request could not be performed because of an I/O device error.
  • RDRCEF.exe application error; application was unable to start correctly.
    Please help?

An Input/Output error indicates an interface (Connector) issue. If you have tried replacing the USB cable, re-installing all drivers, and testing different computers then unfortunately the device’s controller has failed.

A failed controller does not normally allow for interaction with the unit for data extraction or formatting, and the best approach would be to replace the device.

Thanks for your response. If I understand you correctly, the device is shot. If that’s the case is there anyway to get at least one of the backups stored on it?