Cannot access dashboard

Hi Guys,

New in here, very helpful site, full of great information - hope somebody can help a newbie out?

I have just bought a MyCloud 4TB Nas Drive, it is visible on my PC and i can add files etc. What i cannot do is access the Dashboard (to check firmware etc), it says the device is unobtainable?
I have tried to port forward the device in my Sky Q Router, but am at a loss regarding what ports to forward and could do with a walk through. If i type in my Drives IP address in explorer, it just times out?

Can anybody help, its driving me nuts!

Regards

RLG

Officially you cannot access the My Cloud Dashboard from outside of the local LAN/Network. You must be on the local LAN/network. Note if you purchased a My Cloud Home device, that device is different than the My Cloud device and does not have the My Cloud Dashboard.

Port forwarding is generally used for routing certain traffic broadband/internet traffic through the router to the local network. For local network access to a My Cloud one should not need to do port forwarding within the local network router.

If that is so, how can i check firmware etc - i am wanting to use unofficial apps as shown in numerous post on here. I cannot believe that they cannot be accessed from their IP as any other network device can?

RLG

What unofficial app?

One can access the My Cloud Dashboard using the local network IP address for the My Cloud. What one cannot do (officially) is access the My Cloud Dashboard from the Internet or a remote location.

The My Cloud Dashboard should not be confused with the MyCloud.com web portal. They are two different web addresses that address two separate features.

The My Cloud Dashboard example:

The MyCloud.com web portal example:

Unofficially one can access the My Cloud Dashboard from a remote location but it involves setting up a VPN connection/tunnel into the local network (VPN Client/VPN Server) or one can attempt to modify the My Cloud firmware using SSH to allow for internet access to the My Cloud Dashboard.

Hi Bud,

Thanks for the reply - it would appear, after checking i have the My Cloud Home 4tb. Really annoyed, paid a lot of money for basically…a large hard drive! I wanted to use 3rd party apps, run an Emby(not Plex) server and cannot do any of it. Well.***…

RLG

There is a dedicated subforum for the My Cloud Home if you haven’t seen it already.

https://community.wd.com/c/home-cloud-storage/my-cloud-home

As people are discovering the My Cloud Home is a completely different device with different features and capabilities. It does not have a “Dashboard” and apparently doesn’t support firmware level access via SSH (AFAIK).

I can not access the dashboard. I have tried the 4 & 40 sec resets and it doesn’t find the drive when using the .local on my browser. I am MAC based with the latest OS. The WD App Manager doesn’t see the drive either. I want to get to the settings menu so I can do a factory restore and start over. I have tried everything I have read here, but to no avail. I can get to the dashboard by entering the IP address in Chrome, but it just displays the 7 icons at the top and I just keep getting the “wait” or “exit” pop-up. The page never loads completely and I can’t access any of the icons by clicking on them.

Do you have a My Cloud or a My Cloud Home device?

They are NOT the same. The My Cloud Home does not have the Dashboard, and uses a different mobile app than the My Cloud uses.

If you have a My Cloud device then first check to see what color the front LED is. If blue then check the back network port LED’s to see if they are lit and showing activity. Some web browser extensions/add-on’s can possibly interfere with the loading of the My Cloud Dashboard. Try to disable all extensions/add-on’s then attempt to access the My Cloud Dashboard.

In certain rare cases certain ISP routers are known to have a conflict with the My Cloud device. The workaround is to use a network switch between the My Cloud and the router.

Thank you for your help.
I have a My Cloud. The front light is a solid blue and the back LEDs are green. I will check into the router, although, it is a Comcast, Netgear router. There isn’t much I can do about that.

If possible try using another computer or mobile device (if one is available) to see if that computer/device can access the Dashboard.

Other suggestions. If you are using any security software on the Mac try disabling it. It’s possible the security software may be interfering with accessing a local network My Cloud. Try using Safari (if you haven’t already) to access the My Cloud. Also try using Finder to see if you can access the My Cloud at the file manager level.

I can access My Cloud via the finder without a problem, but that doesn’t allow me to get to the settings. I will try your other suggestions. Thank you.

Hi,

I’m facing the exact same issue with the only difference I’m on a Mac running MacOS Mojave. I can access files through finder but am unable to access the dashboard, just throws me “network changes have been detected”. Also, I cannot access it through my iPhone anymore. Reaches a session timeout each time I’m trying.

My PSP uses DHCP and won’t let me use static ip, but from what I understand reading several posts, this should work anyway.

I’m getting really tired of this now, can anyone please help me here? Need to get access from my mobile device so that auto backup starts working again, and I assume I need to access dashboard to grant my mobile device some remote control again (just moved and re-launched my My Cloud device on a new network).

Thankful for all help I can get.

I’m having a similar problem. I’m running the latest version of Windows 10 Home. I can see and access my WD My Cloud via the File Explorer. I can add/delete/modify files on the My Cloud. What I can’t do is access either the dashboard or MyCloud.com dashboard. This all started when the only thing showing up on WD Access was “About…” and “Exit”.

I’ve checked all the network settings and applied the various “fixes”. FYI, I’m a retired PC Systems Consultant of over 30 years… so, I know my way around PCs, Networks, and NASs. But this has me stumped!

Any help or direction would be greatly appreciated.

MyCloud.com is not the My Cloud dashboard it is the remote access web portal.

What specific error message do you receive when attempting to access the My Cloud Dashboard either by it’s name or by it’s IP address?

What specific error message do you get when accessing the MyCloud.com web portal?

Check any third party firewall/security software and or the network firewall. Disable any third party security software as a troubleshooting step and see if the web browser access issue to either the My Cloud Dashboard or MyCloud.com web portal continue.

How to access the Dashboard on a My Cloud device | WD Support
https://support.wdc.com/knowledgebase/answer.aspx?ID=13965

Hi Bennor,

Thanks for such a quick response. I’ve resolved the issue (finally!) after reading an article that talked about the Remote Access ports. Although nothing had changed recently, for some reason, when I finally (after about 20 tries) connected to the dashboard via IP address, I found that the NAS was connected remotely via “Relay”. The article I found, gave instructions for opening the correct ports on my router. After setting the NAS’ IP to Static and forwarding the ports (80 and 443) to the static IP, the NAS finally connected directly (vs by Relay).

Prior to finding this fix, I was NOT receiving an error. What was happening was: