Can’t access with explorer on 1 of 3 Win7 pc’s

I have used my WD My Cloud Mirror without a problem with win7 and win10 pc’s since I have bought it more than a year ago. Now I have upgraded my main pc with a new motherboard and other stuff en reinstalled windows 7. The pc runs fine without any problem. But since then I can’t access my nas with explorer and with my cloud software with problems. With Internet explorer I can access the user interface for the configuration. I have a normal wired network setup. I’ve also tried to access with Wi-Fi but with the same problem. I’ve tried another router with default settings but still the same trouble. Also tried with different IP addresses and static IP address without a result.

Can someone please help me?

Thanks in advance!

Was Windows 7 fully updated? Did you change the Network and Sharing Center settings to match your other computers? Are you able to access other NAS devices on your network?

Hi Trancer, thanks for your reaction!

My Windows 7 is fully updated (incl SP1). The only thing a have changed on the network setting on the NAS is to give it a static IP address after I remarked the troubles to get connected. If I set it back to DHCP, it make no difference. I have only one NAS so I have no experience with others.
If I install the “WD My Cloud” software I can access the NAS with this software but not in explorer.

More ideas?

A recent Microsoft update to Win 7 (thanks, Microsoft) made SMB 2.0 the default for Win 7. I lost connectivity to my MyCloud device recently, even though it had been working for over a year.
Here’s a link to the real fix:

Note that after you take the action in the link you’ll need to stop/restart the 'Workstation" service on your PC to make it take effect.