Can see 2tb WD Elements in 'my computer' but cannot see folder to transfer files into

Hi All

Would really appreciate some help with this as I’ve tried everything I can think of.

I have several WD external drives and never had a problem with any before. I recently got a 2tb WD Elements. It installed normally and was recognised as a drive under ‘my computer’ and I could click on the drive as normal to open it but there wasn’t the usual folder where I could drag the files into that I wished to store. It said it had 1.8tb of free space. I don’t use WD smartware to transfer files as I find it cumbersome. My other WD drives still work fine - it just seems to be this one.

Things I have tried:

  1. Checking it is in Device Manager, uninstalling it, restarting computer and reinstalling the drive
  2. Did a ‘quick format’ to ensure it was in NTFS. It was already in NTFS but formatted anyway.
  3. Ran ‘Check Disk’
  4. Defragmented it

I’m using a Vista 32bit, Dimension C521

Any help greatly appreciated.

Many thanks


Try running a test with DLG, if it fails, replace it.