Can read, cant save to MyBook HD

I purchased my WD My Book 2TB external HD 10/2014.  It is being used mainly for bulk storage (photos and music) with my Dell Latitude E6440 laptop.  I am not using it to back up my laptop.  My operating system is Windows 8.1 and I am running Office 2013.

The WD HD was working well, I could save files to the HD and extract files all ok.  But recently (2 months ago?) I could no longer save anything to this HD and could not change files on it.  I am still able to access everything on the HD normally, I can do a back up of the HD using another HD, but I am not able to save anything new onto my WD HD.

If I try to save something to the drive it comes up with Error 0x8000FFFF

There is over 1TB of space on this drive, so it is not ‘full’.

Is this a software update issue on my laptop?  If so, what updates do I need.

I have looked at all the trouble shooter titles and many community posts and none of them seem to cover this problem (that I could see… and I did many pages!).  Thanks.

Hello and welcome to the WD community.

Have you tried to connect the device to a different computer to see if you get the same results when you try to copy to it? Hope this helps narrow down the causes.

Hi ArMak,

Yes, I tried plugging the drive into another computer but get the same issue.  The drive appears to be working normally in all ways, except it doesnt allow me to save anything new or re-save any modified files.


By any change was this drive used on a Mac and then on a Windows? If this is not the case, try to check the permissions on the unit it could be a permission issue.