Can not copy data from My Home Cloud Duo

I have a product which is overheating frequently - I think the fan has stopped working completely. Done various testing and WD have offered to replace under warranty. I need to get my data off the drive. This is where I am running into problems.

I have various other drives I can move the 4tb+ of data too, but whenever I try to transfer it either via the USB or via file explorer in Windows it is just ridiculously slow (i.e. 20 seconds per photo) so it would take forever to transfer the data. It appears to stop on occasions, although no error message.

I have tried a reset and it hasn’t made a bit of difference. I also tried removing the drive and connecting to my PC via a SATA reader/usb but the PC couldn’t see it. I can’t think what else to try. I’m keen not to lose data - that was the whole reason I got a DUO, so the data was backed up on the second hard drive.

I can see my files without a problem (on the PC and in the online access), and they open individually.

I am using windows 11. After 3 hours it is still on 0% transferred and showing ‘calculating’ rather than copying in the window progress box.

Hi @AdverseTangent,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: